Only mouse showing up - Mac


#1

Hi guys,

I do appreciate that you only support PC. However after over a year using your PLUGABLE USB 3.0 TO 2K HDMI on a Macbook Air today a really weird thing happened. On the screen only my mouse shows up, the rest (desktop background, any window open…) doesn’t.
Do you have any other customers who reported this, and if so, is there a fix? It’s been almost over a year, so I wonder if it’s a hardware related issue.

Thanks


#2

Hi There,

Thank you so much for reaching out to us, I am sorry to hear that you are running into this issue, but I would be happy to assist!

We have seen this issue occur when individual customers upgrade to MacOS 10.13, without first removing the older driver version from DisplayLink. Did the issue start to occur after updating?

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Hi Marc,

Thanks for the prompt reply. You are totally right, I updated to MacOs 10.13 this weekend. Are there new drivers available or should I uninstall the older drivers first?


#4

Solved using the following; http://plugable.com/drivers/displaylink


#5

Hi Aepac,

Thank you so much for updating your system! I am so glad to hear that everything is now up and working. The individual link you supplied is the correct driver to install, and I appreciate you taking the time to install.

Please do not hesitate to reach out in the future if you have any additional questions or concerns, and I would be happy to assist.

Thank you for time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#6