Only getting 1040 Mbps from a Telus 1500 Mbps fiber connection on a high-end Dell XPS laptop with Xeon CPU with Windows 10

Telus fiber connection is 1500 Mbps down and 1000 Mbps up.

Telus modem is a Technicolor FXA5000 and its port port 5 is capable of 2500 Mbps.

I have tried on two Dell laptops both the default driver and latest 2022 driver from the Realtek site:

  1. XPS 4 core / 8 thread with Windows 10.
  2. XPS 8 core / 16 thread with Windows 11.

Both Windows say its a 2.5 Gbps link. And logging on to the modem, it also says the port is using 2.5 Gbps.

I’ve also tested with 3 different CAT6 cables. Same result.

Whether it’s speedtest web or, the speedtest app, I only get max download 1050 Mbps on laptop 1 and max 994 Mbps on laptop 2.

How to fix this?

Hello Simon,

Thanks for contacting Plugable and welcome to our forums! I can certainly assist to investigate this issue regarding the network speed of your Plugable ethernet adapter.

We have a troubleshooting software tool that can give me some more precise details on how the ethernet adapter is being. Please plug the ethernet adaptor into your computer, then go to this page and follow the instructions there:

This will generate a .zip folder on your desktop, please send that folder in your follow up email.

I would recommend to contact us directly to our support email, we can take a deeper look at log files and provide further guidance.

Please visit our contact page and you can reference ticket 390274 in your email,

I look forward to hearing from you soon!


Product Owner
Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.