Only 1 Monitor working with 2017 Macbook Pro

I’m trying to use a UD-ULTC4K Doc with my 2017 Macbook Pro. This dock works with my 2023 macbook (which I use for work) but it doesn’t work with my personal 2017 Macbook Pro. When connected to the doc, the computer doesn’t charge and only 1 of the displays connects.

Here are the specs of my 2017 macbook:

Processor: 2.9 GHz Quad-Core Intel Core i7
Graphics: Intel HD Graphics 630 1536 MB
Memory: 16 GB 2133 MHz LPDDR3
OS: Ventura 13.6.4

I’ve installed the 1.9.0 version of DisplayLink Manager and tried powering of my computer and the dock multiple times with no luck

Hi @gabrielchristiansen,

Thanks for posting!

The fact that your 2017 MacBook Pro isn’t even charging is definitely unexpected, and we’ll want to take a closer look. My initial suspicion is that the dock’s DisplayLink Manager App has not been installed (or its permissions have not been properly granted), but I understand you’ve done this already so we’ll need to see if that process may have gone wrong.

Firstly, can you confirm that the DisplayLink Manager App is running? You should see the icon on the top menu bar:

If it’s not there even after you’ve installed it, the app may simply not be running. You can start up the application by navigating to your Applications folder and launching the app.

However, if all that looks fine, I’d like to proceed by requesting some logs from your personal MacBook Pro to see what could be going on. To do this, please keep the Plugable UD-ULTC4K docking station connected to your computer, then navigate to our PlugDebug tool and follow the instructions there.

This will create a ZIP file on your Desktop containing system logs and information. Please send this to us at and include “Ticket #426032” in the subject line. We’ll take a closer look from there.

Thanks for giving us a chance to help!


Hi Mitchell. Yes the app is installed and I can confirm it’s running. When it’s not running none of the displays work. when it is running, just one display works (but computer still isn’t charging). I’ll get the plugDebug tool and try that

Sounds good. We’ve received your system logs and I’ll be in touch with next steps.

Thank you!


Hi @gabrielchristiansen,

After reviewing the log files, I can see that while the Plugable UD-ULTC4K dock was connected, the Mac reports that no charger or power source is connected. I’d like to start off here.

Let’s proceed by resetting the system management controller (SMC) on the Mac, which can help resolve issues related to charging. To do so, please refer to the following steps:

  1. Shut down your Mac.
  2. Disconnect the dock from the computer, then disconnect the power adapter from the dock so that it is fully powered off
  3. On your built-in keyboard, press and hold all of these keys:
  • Shift on the left side of your keyboard
  • Control on the left side of your keyboard
  • Option on the left side of your keyboard
  1. While holding all three keys, press and hold the power button as well.
  2. Keep holding all four keys for 10 seconds.
  3. Release all keys, then press the power button to turn on your Mac.
  4. Connect the power adapter back to the dock
  5. Reconnect the dock to your computer via the included USB-C host cable and observe the behavior

Please let me know if this helps at all and we can take the next steps from there.

Thanks for your patience!


I’ve tried all these steps and no luck. Additionally, the support rep helping me has stopped responding to my emails

Hi @gabrielchristiansen,

Sorry to hear this did not help!

It appears we haven’t heard from you since your last message on Feb 9th. Please let me know if you’ve sent out any other emails – we may not have received it.

We’ll continue to focus on the 2017 MacBook Pro since the dock is working fine on your work 2023 Mac.

Firstly, can you clarify if you’re seeing the same issue when the dock is connected to any of the Thunderbolt ports on the system? Please do try ports on both the left and right side of the computer.

If so, let’s try installing the version 1.10 of the DisplayLink Manager App to see if that makes any difference. Please uninstall the current version of the app (simply drag the app to the Trash bin). Then, install the DisplayLink Manager App ver 1.10 here:

Thanks again for your patience!


I sent multiple emails but no response…

Anyway, I have tried all 4 thunderbolt ports - but the same result on all ports. I installed 1.10 of DisplayLink Manager, but same results.

Additionally, while everything works ok on my work computer (2023 macbook), every time I connect to my personal and then connect my dock to my work computer again, the work computer stops working with the dock until I unplug the dock. Same happens for when I try to plug into my personal computer - if the dock was previously connected to my work computer, I have to unplug before it recognizes my personal computer (but in that case only 1 monitor ever works)


Apologies for the communication troubles on this.

Given what we’re seeing, I think it may be best to get you a warranty replacement to help rule out any strange hardware issues with either the dock or its included USB-C cable. I will follow up with you directly to start this process.

Thank you!


Hi Mitchell. I haven’t heard anything else… wanted to make sure I didn’t miss an email from you.

Hi @gabrielchristiansen,

I had sent an email to you last Thursday! Here is the contents of that email:

Given what we’ve tried already and the issue at hand, I’d like to go ahead and send you a warranty replacement dock to help us make sure that the dock hardware is working as expected.

To get this process started, I’ll just need the following pieces of information:

  1. The Amazon Order ID (or other proof of purchase) associated with the Plugable dock
  2. The serial number located on the bottom of the dock
  3. A full name and preferred shipping address

Thank you!


I didn’t receive that email. I don’t want to post that information here publicly, can you please tell me what email to send the info to? I only see noreply email addresses.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.