Older UBB 3.0 hdd docks not working with 3tb drives.


#1

I have three of the plugable usb 3.0 hd docks. I’m having a problem with two of them not recognizing 3tb hard drives. These also happen to be the two that I bought together a while back. The one I bought a couple months ago works fine with both 3tb drives that I have.

The two docks that are having problems with the 3tb drives work fine with my 2tb (and less) drives.

The 3tb drives (in the two docks that aren’t working) do show up in Disk Management/Storage Management. However they show up as unitialized and unallocated. When I try to initialize them, I get error: The request could not be performed because of an I/O device error. I’ve tried both GPT and MBR…both give same error. Once again, the drives work fine in the newer dock. They come up initialized and have been formatted, working fine, etc.

I’ve upgraded the firmware to: LUCIDPORT U300 Sata/Usb 3.0 Controller firmware 2580. Still no go.

The docks are connected via your plugable pci-e expansion cards…latest drivers installed.

The variable that seems to be the consistent culprit is the 3tb size.

Do the old docks not support 3tb drives? Your help is appreciated.

Thank you.


#2

Hi Matt,

Thanks for posting your question here, we’ll be happy to help. And, thank you for providing such great detail! It really helps to get a clear picture of your setup and what’s happening.

Here’s a couple of quick questions:

What operating system are you running?

Are you able to format one of the 3TB+ drives in the LucidPort dock? You’d have to move the data off, so hopefully that’s not too much to ask.

If you can format the large drives on the LucidPort dock, before copying data over to the 3TB drive, make sure that it is readable by the newer dock as well.

Let me know these details and we’ll figure out the best next steps.

Thanks,
Jerome


#3

Thanks for your quick reply.

I’m running Windows 7 64-bit.

I can’t format the 3tb hdd in the two older docks. It won’t even initialize, so it won’t allow me to add a “simple volume” and format it. However, I will note that in Disk Management it does show the correct GB size. But that’s about it.

I can successfully initialize, create a simple volume and format the 3tb hdd in the newer dock. It works fine, transferring files back and forth. However as soon as I put it in one of the older docks, It shows up Not Initialized and space Unallocated. When I try to initalize it, I get the aforementioned error.

If I do the above steps (format in good, transfer to bad and try to initialize w/error), when I put the previously formatted drive back into the newer/working dock, it shows up online, but space becomes unallocated again and I have to reformat.

I also tried swapping usb cables between one of the older docks and the newer dock. Thinking it could maybe be the cable and/or the pci-e card. But both docks continue to behave the same way with each other’s cable.

I’ve also noticed that sometimes, if I leave a 3tb hdd in one of the older docks, it wrecks havok on my computer. Like it won’t shut down…or it won’t boot up…it will just hang at the “windows starting” screen. Then once I turn off the older dock, it will then immediately continue to boot up. It’s really weird…especially, since this doesn’t always happen in a repeatable way.

At one point, I even did a clean reinstall of the OS because my computer was so on the fritz. I didn’t know at that point what was causing the problem…doh!
After I switched the 3tb to the newer dock, all was well again.

I haven’t bothered with it since, because I only had one 3tb hard drive (WD Caviar Red). But now I bought a 3tb Caviar Green to use as a daily backup, which I want to put in one of the other docks. Thus my current sticky situation.

Once again, thanks. I appreciate your help.


#4

Nevermind…got it working!!! I went to try one of the older docks, and to my surprise it was working. So I tried the other non-working dock, but that one was still not working with the 3tb hdd’s. So I flashed the firmware again on this dock, and now all is working. I thought for sure that I flashed both chips, but the first time I must have only hit one of them. So after flashing the other one, all 3 docks are working great.

Your products and support are fantastic.

Thank you!!


#5

Hi Matt,

Thanks for taking the time to let us know! I’m glad to hear that you found your solution. Just let us know if there’s anything else we can do.

Best Regards,
Jerome.

Plugable Technologies


#6

Hi Jerome,
I have a Western Digital “My Book” 1TB HDD. When I connect my Win 8.0 Dell 15Z laptop to the Plugable USB 3.0 Docking station (7.3M0 drivers) ( it (sometimes) fails to recognize the MY Book HDD. If I remove power from the My Book and then restore power, it comes up fine and is recognized. Any thought about how this can be fixed? - Brad


#7

I have a problem with my USB 3.0 docking station also. I have a WD Black 3Tb drive; I can create a gpt disk, and I can quick format, but the long format fails…I can read the disk (after quick format) in Windows 7 64 bit UEFI laptop and copy files. But doing something more time-extensive, like running a full backup to it, fails. I get io error…


#8

Hi Donna - If the long format fails, definitely something is wrong, perhaps with the drive. Please email us at support@plugable.com and we’ll try to figure out which component is failing (if you haven’t already).  Thanks!


#9