Oh no! Is my adapter fried?


#1

Hi, Just got my USB3.0 to HDMI adapter. I’m running a windows 7 (64 bit) PC. I installed the 6.3 drivers from the site, and then plugged in the adapter. Immediate blue screen of death. Proceeded to try and uninstall the plugable drivers but was unable to. Also the driver for my video card (Nvidia) was bollixed. So I re-installed the driver and rebooted. No good, still a BSOD. After many attempts, I was able to get the Nvidia drivers installed and then reinstalled the plugable drivers too.

Now when I plug in the adapter to a USB port, absolutely nothing happens. Nothing whatsoever. To make sure it wasn’t the usb port, I tried plugging in a flash drive. It worked perfectly. I then downloaded the drivers on my macbook pro and tried the adapter on it.

Same result. Nothing happens. Its as if the adapter is dead.

Is this the case or can I try something else?


#2

Hello from Plugable Technologies. We got your message that you sent on this topic to our private support system and have responded from there. Look for an e-mail from support@plugable.com and continue the conversation by replying to it.

I will add here that you cannot use the USB 3.0 to HDMI/DVI adapter with a Mac–it never will work there–so the adapter may be fine. We will continue to work with you through the private system to get your display situation on your PC to the configuration that you desire and with no BSOD. I will close this public ticket to avoid confusion.

Best Regards,

Aaron
Plugable Technologies


#3