Nothing happens when I plug the USB display adapter in


#1

I plugged a UGA-2K-A USB display adapter into my Windows 7 laptop. Windows did not display a “found new hardware” message. It looks like there is a green light on the unit. It does not light up. In short, nothing happens when I plug the device in.


#2

Hi Jim,

Thanks for posting! We’re sorry the adapter is experiencing a problem here.

For the LED to turn on, both the hardware and the driver have to be running properly - so it makes sense that if we’ve not gotten a “found new hardware” pop-up bubble, that the LED is off. We have to assume no driver is loaded.

Can you try a few things:

  1. Unplug and replug all connections to make sure they’re tight
  2. If you have the adapter plugged in through a USB hub, try connecting directly to your PC
  3. If you happen to have a spare USB A to mini-B cable around from another device, try swapping in that cable
  4. With the adapter connected, let’s try to find any sign of the device in Windows 7’s Device Manager (like a device with an error). In the normal case, the UGA-2K-A should appear like this:
    !](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0iX78zBWh1iRF0s8DOsTqBXQEP4gDj7ECX0JypwH3-c7PxAW0uLiqju-t1A37pPdaUEA-t8pazVyfbS1SPmGlXA=.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/415878/win7-uga-2k-a-device-manager-normal.PNG)

If these quick double-checks turn up any interesting signs of life, let us know. Otherwise, if there’s still no sign of the device when you plug it in, it’s unfortunately possible you’ve gotten a bad unit. In that case, please just email your Amazon order number to support@plugable.com and we’ll be happy to get you fixed up.

Thanks for your patience!
Bernie


#3

From my experience, it is USB port problem , you can connect this device with another USB port of PC, or, change one new USB cable ,then follow the above operation


#4

I have this same problem. My Adapter worked for a day or 2, then justquit after a reboot. I’ve tried

Any advice would be appreciated.

Steve


#5

Hi Steve,

What you’re seeing in Device Manager (“USB Display Adapter”) is unusual. Normally it would be a specific model of DisplayLink device, not generic like that.

If you have a Plugable adapter, just email your Amazon order # to support@plugable.com and we’ll be glad to take care of you.

Thanks!
Bernie


#6

There must be a problem with this adapter. If I reinstall the software, when I plug in the adapter, it works once. If I reboot the computer, the USB adapter is not recognized. The only way I have been able to get the adapter to work is by uninstalling and reinstalling the software.


#7

Hi Mike - Thanks for posting. Your symptoms sound a little different. Could you run DisplayLink’s support utility (here’s how: http://plugable.com/support/tools/dis…) and email the .zip file it generates to us at support@plugable.com? From that, we’ll be able to figure out next steps. Thanks! Bernie


#8

The utility does not complete. It says there is an error in line 6393 and that the object could not be completed. This computer has a bad LCD (it’s an HP laptop that is subject to a class action lawsuit), so reading on the screen is a challenge.


#9

Hi Mike - we haven’t seen that before … a sign that something unusual is going on. We’ll go at it a different way. Could you try two things:

  1. Uninstall the DisplayLink drivers and re-install a particular version of drivers – 5.6 M1, downloadable here: http://displaylink.com/support/sla.ph…

And let us know if that particular version of drivers helps. And if not …

  1. Could you run Windows’ built-in “msinfo32” utility, select Components->Display, and send us the information on the right? (Name, PNP Device ID, Adapter type …)

!](https://s3.amazonaws.com/satisfaction-production/s3_images/654305/msinfo32-display-info_inline.PNG)](https://s3.amazonaws.com/satisfaction-production/s3_images/654305/msinfo32-display-info.PNG)

Hopefully we’ll be able to see what’s different.

Thanks for your patience!
Bernie


#10

Bernie:

Here is a picture of the error on the screen. (I have to log into the computer with Windows Remote Desktop to see what’s on the screen.)

I’m trying the driver you suggested, but the process is tedious since I have to use the laptop monitor to keep the drivers from getting confused.

Mike !](https://s3.amazonaws.com/satisfaction-production/s3_images/654321/plugable01_inline.png)](https://s3.amazonaws.com/satisfaction-production/s3_images/654321/plugable01.png)


#11

Hi,

I just buy a new display adapter UGA-2k-A. I Installede the driver from the disk and alos the lastest version from the web. It does not turn the light on and keep giving me the following error message.

!](https://s3.amazonaws.com/satisfaction-production/s3_images/703913/Display%20Adapter%20Error_inline.jpg?1330203010)](https://s3.amazonaws.com/satisfaction-production/s3_images/703913/Display%20Adapter%20Error.jpg?1330203010)


#12

Hi Edgar,

Thanks for posting here! This is an old thread with many different issues than what you are seeing. Could you shoot us an email at support@plugable.com along with your Amazon Order ID so that we can help troubleshoot the issue?

Regards,
Roze


#13