Not Sensing USB 3.0 Speed When Using 3.0 Cable


#1

I’m using your USB 3.0 Dock station and your PCI Express to USB 3.0 2-port expansion card. When I intially installed it, I was getting a message saying that the “USB 3.0 would transfer faster if connected to a superspeed port.” Loading the firmware (2447) update solved that problem until now.

I’m the guy who was using an IDE converter with your dock to transfer some old files. After I finished doing that, I was using your included 2.0 USB Cable to attach the Dock, I removed the converter and installed a SATA drive in your Dock and attached it with your included 3.0 Cable. I power up the dock and turn on my computer (Windows XP Pro) and I get the old warning message again “USB 3.0 would transfer faster if connected to a superspeed port.”

I don’t know if the problem is in your PCI Express card or the Dock? Is there a fix for this?
Thank you.


#2

Hi Bill,

Thanks for posting again. Let’s try to figure out where the problem is.

The earlier benefit that you got from the sata dock firmware upgrade was to make the dock more tolerant of USB transfer errors. These are often caused by the USB 3.0 cable, but could be on either side device too.

So I’m suspecting that the new problem of dropping back to USB 2.0 may have a similar cause.

Let’s try to isolate it down.

If the USB 3.0 cable is coiled or near other cables, can you straighten it out and make sure it’s not wrapped/near any other cables or power adapters? I know this can be difficult, because USB 3.0 cables are rather unflexible.

Then try an unplug/replug from one port into the other on the USB 3.0 card (or, if you’ve gotten the speed warning on both ports, do a reboot). This is because drivers and OS can sometimes persist a port in a fall-back configuration.

Let us know if either of these steps helps. Then we’ll figure out next steps.

Thanks for your patience!
Bernie


#3

Hey Bernie - I haven’t yet tried what you suggested but I found something interesting today. First, my 3.0 Cable is looped in a half circle all by itself and is not close to or touching any other cables or power adapters. But here’s what’s strange.

It seems when I get the error message “USB 3.0 would transfer faster if connected to a superspeed port” it happens when I turn the Dock’s power switch on prior to booting up my computer. Today,for example, I tried making sure the Dock’s power switch was off before booting up my computer. Then, after I booted up to the desktop, I turned the dock power switch on and my drive appeared and I DID NOT get the transfer speed warning message. Maybe if I continue to follow that power-up sequence it will be OK?

My drive access seems very fast so I’m assuming it’s working at 3.0 speed but I haven’t used in for editing with my NLE yet so I don’t really know. Do you know of any quick test I can run to verify that it’s operating at the correct speed?

Thanks again.


#4