Not Detecting my second external screen.


#1

I have two identical monitors, connected to my Plugable Superspeed USB 3.0 Dual Monitor Docking Station. The first is connected by DVI and works properly. The second is connected via HDMI to the Display port of the monitor and does not display. I’ve rebooted the computer, unplugged and replugged the dock and checked to make sure the driver software is up to date.

Not quite sure if I selected the appropriate product on the right side of the screen.


#2

Hi Peyton,

Thanks for posting. I would be happy to help with your docking station!

The cable you are using to go from the HDMI output of the dock to the DisplayPort input of your monitor is most likely a passive unidirectional cable. This cable can only be used to go from a DisplayPort output to a HDMI input, not the other way around as you are doing.

You don’t mention which model monitor you have but assuming the monitor does not have a HDMI input, if it does have a DVI input you can use an inexpensive HDMI to DVI cable (for example http://amazon.com/dp/B00K7HECTQ) instead as those cables are bidirectional. I’ve written a little about the various cable options with our dock if you are interested -> http://plugable.com/2015/07/06/video-…

Let us know if that helps when you have a moment and we’ll go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3

I believe that was the problem. We will try the HDMI to DVI cables you suggested.
Thanks.


#4

You are very welcome. Have a good day!

Bob


#5