Not detecting 2nd external screen


#1

Purchased SuperSpeed USB 3.0 Dual Monitor UD-3900. I have two identical DELL external monitors to be utilized along with my laptop monitor. Both external monitors are only VGA cables. I have a VGA to HDMI connector, which I used and the monitor would turn on. The second VGA cable I utilized the VGA to DVI adapter that came with the docking station.

No matter how I do it, I can only get one monitor to work as an external monitor.

Any ideas? Thank you!


#2

Hi Casey,

Thank you so much for reaching out to us, I am sorry to hear that you are running into this issue, but I would be happy to assist!

Just to make sure I have all of the right information, when you connect the two displays, and then head into “Display Settings” do you see multiple “boxes” indicating that the displays are connected, but not inputting? If you can, please take a screenshot and send it to our support address at support@plugable.com, and please put “Ticket No. 199852”

Also, when you do get one of the monitors to work, which one is it? Or do both monitors connect and work one at a time, but never together?

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#3

Hi Everyone,

We attempted to reach out to Casey to see if we could help work through some troubleshooting, but we have not received a response back. If Casey, or any other customers, are running into any similar issues, or would like to continue troubleshooting, please feel free to reach out to us at support@plugable.com.

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#4

Same problem here. I have two brand new dell monitors for home. I bought a new plugable docking station for home but I can only detect the laptop monitor and one of the dell monitors( the one connected via hdmi to DVI cable) . the other monitor w hdmi to hdmi is a no show. tried driver installs from dell and from plugable


#5

Hit windows + X

Device manager

display adapters

right click your display (microsoft something)

properties

Driver

Roll back driver

Takes to previous version, which works for both displays. Not sure why updated version didn’t work, maybe it will in the future.


#6

Hi Al,

Thank you so much for reaching out to us! In order for us to help resolve your issue, I think a great next step would be to head over to www.plugable.com/support/plugdebug and download and run our diagnostics tool. Once the application finishes, please send the .zip file that will be saved to your desktop to support@plugable.com, and we can help work through some troubleshooting to resolve the issue!

Thank you for your time,
Marc
Product Owner & Technical Support
www.plugable.com/support


#7