No video output with Lenovo notebook and displayport to hdmi cable

Laptop: lenovo 15.6" thinkpad p15s
OS: Windows 10
Dock: Plugable UD-ULTC4K
Monitors: Asus pg279q 2x (g-sync)
Cables: 4K DisplayPort to HDMI Cable Adapter, WARRKY

Using the included USB-C cable, I have my p15s hooked up to the ud-ultc4k dock. From the dock I have the displayport to hdmi cable hooked to the HDMI port on the pg279q monitors. I switch the input on the monitors to HDMI but do not receive any video output.

On the laptop I’ve tried windows+P to setup displays and when I go into display settings to detect new devices, I’m shown an error that no devices were detected. I’ve not installed any of the driver software, because from the documentation I probably shouldn’t need it, but i’m willing to do so.

I’ve seen other support messages that say to disable gsync but that was for the displayport side and I’m not sure if that applies to HDMI. I also don’t see a way to disable it on the monitor settings anyway. I have also tried to use a known good full displayport cable and I still receive no video from the docking station.

I tried the docking station again with another monitor that only supports hdmi and it would not work either, no display output. I’ve tried it with both ports on the usb-c 4k dock as well. The single hdmi output on the dock does work when plugged into the same monitors HDMI slot. I have verified the cables are good going straight from my PC (displayport) to the monitor HDMI port.

Lastly, when I plug the dock into my laptop I get a Unknown USB device (port reset failed). Removing the USB-C cable removes this failed device.

Any help anyone can provide?


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Let’s have you proactively perform a full clean install procedure of the DisplayLink to ensure there are no older drivers present that could be causing issues with the newest drivers from auto-installing via Windows Update. Without them the two DP ports won’t be able to function.

Here’s how:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel → Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step.

  3. Download, extract and run the DisplayLink cleaner tool, found here → and ensure it displays “Cleaning Complete” when done (video walk-through if you need it →

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 10.1 M2 DisplayLink software, found here →

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

If this has not helped please let me know and we can go from there.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies

Thank you for your response.

I have not installed any of the plugable software on my laptop yet. I will try to install it and see if my results are any different. Thank you for the links.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.