No sound under Kubuntu Linux from headphones with USB-BT4LE


#1

I am having problems similar to those described in
http://plugable.com/2014/06/23/plugab…
I am running Kubuntu 14.04 LTS and am using a brand-new USB-BT4LE.

Following the instructions on that website, I copied the driver file and
renamed it several times:
$ ls -l /lib/firmware/brcm/BCM20702*
34700 Aug 13 2015 /lib/firmware/brcm/BCM20702A0-0a5c-21e8.hcd
43 Apr 28 19:21 /lib/firmware/brcm/BCM20702A1-0a5c-21e8.hcd -> /lib/firmware/brcm/BCM20702A0-0a5c-21e8.hcd
43 Apr 28 19:22 /lib/firmware/brcm/BCM20702 Bluetooth 4.0-0a5c-21e8.hcd -> /lib/firmware/brcm/BCM20702A0-0a5c-21e8.hcd

The headset (a SoundBot SB220) pairs and says it connects, but there is no
sound. Sound comes out instead on the built-in audio analog stereo, even
though in phonon I specify SB220 should have priority.

dmesg reports “Bluetooth: can’t load firmware, may not work correctly”

When I boot the same hardware into Windows 7, it works fine, so I’m pretty
sure its a software problem.


#2

Hi David,

Thank you for your message.

The firmware error message is normal and has not been known to cause problems with using our Bluetooth adapter.

I do not currently have Kubuntu installed, however I do have some additional information and things you can try.

According to the documentation for Phonon:

_ Unable to access audio device

If your user account has insufficient permissions to access the audio device, Phonon will be unable to play sound. Please consult the documentation of your distribution on how to ensure that your user account is properly set up. If Pulseaudio is not used, make sure that your user account is a part of the audio user account group.

Sound out of the wrong device

This is related to the point above this. Also make sure that the correct device is listed at the top of the Device Preference tab, which can be found in the Hardware -> Multimedia -> Phonon -> Sound and Video Configuration area of System Settings. In case an audio device isn’t available (an USB-headset unplugged, for example), Phonon will attempt the next device in the list._

I would recommend checking the output of /var/log/syslog in addition to the dmesg output. Typically more information regarding device permission or access issues will show in the syslog.

If the information included above does not prove fruitful toward finding a solution, could you please run PlugDebug (http://plugable.com/support/plugdebug…) and send the output to support@plugable.com with the subject “For Ticket #141020”?

Thanks!

Andy
Plugable Support


#3

Hi David,

I wanted to follow-up on this topic and see if you had any luck with the suggestions given.

Thanks!

Andy
Plugable Support


#4

Thanks for following up, Andy. You made two suggestions, one to check whether I am able to access the headphones, and one to make sure it was set to the top priority in Phonon. I did check the latter and I did that right, but I was unable to figure out how to check if my user account was set up properly to access the sound. However, I have sound through the built-in audio analog stereo, so I assumed I had enough permission and didn’t pursue it further.

I then got distracted by other things and have not yet followed up on running PlugDebug. I will do that soon and send it to support@plugable.com.


#5

OK, so I ran PlugDebug and sent the output to support. Thanks again for asking.
dlk


#6

Hi David,

I am glad that we were able to get Bluetooth audio playback working in Kubuntu as expected. To summarize, the steps we found to work are included below.

If the device has already been paired, it is recommended to do the following steps:

1. Left-click Bluetooth icon next to the clock and choose ‘Configure Bluetooth’
2. Click headset/audio device and choose ‘Remove’.

If the device has not been added yet, or was removed in the steps above, perform the following:

1. Put Bluetooth headset in pairing/discoverable mode according to the device’s instructions.
2. Click ‘Add Device…’ in the ‘Configure - KDE Control Module’ window.
3. Select the headset from the list of devices and choose ‘Next’.

4a. Accept ‘Connect to the Audio service’ and click ‘Finish’
4b. A KDE Workspace notification appears to inform that the Bluetooth device is connected and configured.

5. Right-click the sound icon next to the clock and choose ‘Audio Setup’

6a. In the ‘Device Preference’ tab, choose ‘Audio Playback’, then in the right pane, select the Bluetooth device and put it to the top of the priority list.
6b. Repeat raising priority for the remaining categories under ‘Audio Playback’. (Notifications, Music, Video, Communication, Games, Accessories)

7. Switch to the ‘Audio Hardware Setup’ tab.
8. In the ‘Sound Card’ drop-down menu, choose your Bluetooth audio device.
9. In the ‘Profile’ drop-down menu, choose ‘High Fidelity Playback (A2DP)’ if available, otherwise use ‘Telephony Duplex (HSP/HFP)’.
10. Click ‘Apply’ in the lower-left corner of the ‘Audio and Video Settings - KDE Control Module’ window.
11. Use the buttons under ‘Speaker Placement and Testing’ to validate that sound is being produced. If no sound is emitted, use the volume control on your Bluetooth audio device to raise the volume in addition to raising the volume by left-clicking the audio icon next to the clock, choosing ‘Mixer’, and adjusting the slider for your device upward.
12. Test audio playback from an application. (Before testing, you may want to restart the application if it was already open.)

After completing these steps, all audio should route to the Bluetooth audio device.

Thanks!

Andy
Plugable Support


#7