No sound from Plugable USB 3.0 audio jack


#1

Used to play fine through headphones. Checked Sound settings and Plugable device not an option for playback device (only speakers via HD Audio. Please help).


#2

Hi Simon,

Thanks for posting. I’m sorry the audio output of the dock stopped working properly, and I would be happy to help!

Thanks for checking the Sound settings in your system and letting me know the Plugable Audio choice isn’t present. Our first step is to perform a ‘clean’ install of the DisplayLink driver (which includes the audio component) to ensure everything is in a good state. Please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until step 7.
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… (video walk-through -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. If running Windows 10, please run Windows Update (Start > Settings > Update & security). Reboot if/when prompted. Repeat this process until there are no new updates found. This is important as Microsoft has been releasing frequent updates to Windows 10. If not running Windows 10 just skip this step.
  6. Now download and install the 7.9 M5 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  7. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system when prompted by the installer which will trigger the final portion of the installation
  8. Double-check the Sound settings again to ensure the Plugable Audio is selected as the Default Playback device and test again.

Let us know if that helps when you have a moment and we’ll go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3