No SlingPlayer video on monitors connected to UD-3900

I have a UD-3900 attached to a Dell XPS-15 via USB 3.0 port.
I am trying to run SlingPlayer 2.0.4522. This is a standalone executable, not Sling’s browser extension. The video rendered within the SlingPlayer application is blank when using one of the monitors attached to the UD-3900 (ie using the DisplayLink chipset).
Video is rendered fine if I run the SlingPlayer on the XPS-15’s integrated monitor or a monitor connected to the XPS-15’s its built-in HDMI port
I have also been successful when running SlingPlayer on monitors attached to a Dell’s docking station.
The only failure is with monitors that are connected to the UD-3900. This fails on both the UD-3900’s HDMI and DVI ports, standard display size with skin around video or in full screen mode.

I’m running the latest DisplayLink driver dated 9/12/2017 8.3.2008.0
My XPS-15 has both Intel HD Graphics 630 and NVIDIA GeForce GTX 1050 drivers.
Dell Update says I am running the latest drivers.
I’m running Windows 10 Home Version 1709 OS Build 16299.125

Hi Steve,

Thanks for posting and for the excellent problem report details.

I suspect the issue here is that the UD-3900 (and our other DisplayLink USB graphics products) do not support HDCP content/copyright protection. Though I don’t see anything about an HDCP requirement mentioned in the FAQ for their SlingPlayer app, they mention this requirement on various SlingBox documentation, so it’s extremely likely they are required to enforce it with the app as well. They do mention various workarounds on their site, but not sure that any would apply here.

(We do mention in our Amazon listings that HDCP/protected content isn’t supported, but it’s an easy detail to miss.)

If the dock won’t meet your needs, we’re happy to help with a return for a full refund – please just email along with your Amazon Order ID number and we’ll provide next steps for that.


Well, I don’t think HDCP is the issue
The input to my Slingbox HD-Pro is Component Video or OTA.
As a matter of fact, the HD-Pro doesn’t have an HDMI connection.

Not ready to return your station It’s a pretty cool gizmo less this one anomaly.

I’m wondering if it’s a DirectX issue.
Using dxdiag, my Win10 system supports DirectX 12.
The displays that do work use Intel drivers (igd…64.dll series)
They show a Driver Model WDDM 2.1

The 2 displays attached to the UD-3900 where it fails to render the video use dlidusb2.dll and wudfrd.sys drivers
They show a Driver Model WDDM 1.3

All monitors show the same Direc3D DDI and Feature Levels supported.

I’m also able to run SlingPlayer on a Windows 8.1 box, using NVIDEA drivers and DirectX 11, with Driver Model WDDM 1.2

One other thing I noticed. dxdiag identifies all of the monitors that work as having a Device Type of “Full Display Device”. The 2 monitors that don’t work (plugged into the UD-3900) show a Device Type of “Display-Only Display Device”… It is not the physical monitor. The same monitors that fail when plugged into the UD-3900 work when plugged into a Dell docking station.

Have any thoughts on the difference in Device Types of “Full” and “Display-Only”? Again, the same monitor when plugged into a Dell docking stations shows “Full”, but when plugged into the UD-3900 shows “Display-Only”

Hi Steve,

Interesting, thank you for these details. Full Display vs. Display-Only likely is referring to a full GPU implementation that is actually doing the GPU compute (NVIDIA, Intel, etc) vs. an “indirect” display like DisplayLink which only output, but leverage another GPU for computation.

If it’s not an HDCP issue, this might be a key element, as DisplayLink is working with Microsoft and Intel on solving some Windows 10 indirect display issues which could be the culprit here.

Just to confirm, what’s the model of Dell dock that is working in the same scenario? (If it’s DisplayLink-based I would expect it to behave the same as ours.)

Also, can you please check your Windows Display configuration settings and make sure your laptop’s built-in screen is set as “main” – this workaround has served as a workaround for some of the indirect display OS/driver issues mentioned above.


On the functional XPS-15, the true Dell docking station is a WD15.
Looking at the device manager on that laptop, there is no additional display adapter for the WD15, only
Intel® HD Graphics 530
dxdiag shows all 3 monitors as having a Device Type of “Full Display Device”
and a Chip Type of Intel® HD Graphics Family

Not to confuse things, but I have a Windows 8.1 box (a Dell T3500) with a Startech USB to VGA adapter for a 3rd monitor. Device Manager shows only a single display adapter, a NVIDIA Quadro FX 1800. The SlingPlayer video works fine on that USB connected monitor. dxdiag shows all 3 monitors as having a Device Type of “Full Display Device” and a Chip Type of Quadro FX 1800

On the problem XPS, I have 3 display adapters
Intel® HD Graphics 630
NVIDIA GeForce GTX 1050
Plugable UD-3900
dxdiag shows the internal monitor as having a Device Type of “Full Display Device” and a Chip Type of Intel® HD Graphics Family. The 2 monitors served by the UD-3900 a Chip Type of “unknown” and a DAC Type of “unknown”. And as pointed out before, the Device Type of “Display-Only Display Device”

The laptop’s built-in screen was not set as main. I changed that, but SlingPlayer video still did not render on the UD-3900 monitors.

Hi Steve,

Appreciate the additional helpful details!

Ah, that makes sense re: the WD15. It uses USB-C Alt Mode, so essentially it works as a native display powered by the system’s GPU.

I believe the distinction of “Display-Only Display Device” was implemented in the most recent WDDM update with the advent of the Windows 10 Anniversary Update, so it makes sense things would look different on the Win 8.1 system in that regard.

Can you try the Startech adapter on the Win10 system in place of the UD-3900?


Unfortunately not.
The Win 8.1 machine is 3000 miles away of the Win10 laptops

Hi Steve,

Ah, understood.

One other possibility is worth exploring. DisplayLink is working with Microsoft and graphics card vendors on a bug in Windows 10 with multiple internal GPUs that causes Windows 10 to use the less-powerful GPU for compute for an indirect display (e.g. DisplayLink).

(Several threads in the DisplayLink forum touch on this; some applications will display an error about incompatible GPU drivers when this happens, but others can fail silently.… )

When this happens, typically Windows is using the low power GPU used during boot (Intel) instead of switching to the more powerful Nvidia or AMD card.

We could test if this is the scenario here, but only if your BIOS has an option to disable the Intel GPU and run solely on the Nvidia (and of course if you’re willing to make this change to test). Please note, disabling the Intel GPU in Windows won’t suffice; it would have to be in the BIOS.

If this works, that’s good news, as it means the issue will hopefully be fixed in an upcoming Intel GPU driver update.


It will take me a few days to test. I’m now 3000 miles away from the laptop with Plugable docking station. I can VNC into laptop to continue to experiment, but BIOS stuff I need to get somebody to assist. Standby…

Ah, got it. Will look forward to an update at your convenience.


There are no options in BIOS to disable the Intel GPU. In Windows Nvidea control panel, I did try setting the Nvidea GPU to be used always. No Help. I also tried to set the Intel GPU to be used always, but got an error saying the Nvidea card was incompatible with Intel GPU. Reset things back to automatic. I then went to Intel’s control panel. Interestingly, the Intel control panel tool doesn’t recognize the existence of the DataLink monitors. It shows only the laptop’s embedded monitor (even though the two DataLink monitors are working). I suspect it would show an additional monitor if it were full-fledged being attached to the Laptop’s HDMI port. So I’m back to square one.

Hi Steve,

Got it, appreciate the update.

As you mention, the Nvidia and Intel control panels do not interact with DisplayLink USB graphics adapters, and setting GPU priority there will not have any effect.

(As Microsoft continues to integrate support for USB graphics deeper into Windows, we hope the other graphics vendors will start adding support for USB graphics in their proprietary utilities.)

So based on what we’ve tried at this point, it seems we’re contending with one of two possibilities – either a fundamental incompatibility with the SlingPlayer software, or the underlying issue touched on previously regarding how Windows 10 and multi-GPU systems function with “indirect” USB displays in some applications.

We could see if any driver updates are applicable to your system that might help. If you’d like me to have a look at your system logs and advise on this, please collect a set of system logs using our tool at the link below and email to for me to have a look:

Also, if you haven’t already done so, it would be interesting to see if Sling has any other reports of this or any insight.


Debug information Information has been emailed.

My understanding is Sling has stopped producing and selling boxes as of Jan-2017.
They were purchased by Dish. Dish has agreed to continue to support the SlingPlayer community, but this support is mostly for a cloud based directory service that is used to allow one to find one’s Sling boxes when away from home without the need for dedicated IP or domain name.

They have quite a number of different types of boxes and platforms that their players run on. I suspect they have no intention of tweaking their software at this point in time.

You might check out
I have an PRO-HD and am running with what they have labeled I believe as “Older SlingPlayer software” This is a version that hasn’t been updated since 11/3/2010. Form what I can see, it uses an embedded Adobe Flash Player from that era (About screen shows Adobe copyrighted 1996-2006).

None-the-less, this application runs on a “full” docking station.

Sling has 3 different flavors of their player that can be used on Windows with my HD-PRO Slingbox. I have been using an older ad-free version. So I tried their Slingplayer Desktop and SlingplayerForWeb. Both render the video on monitors connected to the Plugable docking station. Both rely on the broswer (Chrome is my case) to do the heavy lifting. So I have a workaround to get things to work, but with some annoying ads.
I don’t want to close this discussion as the older flavor (which is still supported by Sling) works everywhere except through monitors connected to the Plugable docking station (ie DisplayLink or non Full Display Devices).

I ran the Dell Support Assistant and it did indeed show a new Intel-HD-Graphics driver (4836). I applied that along with an urgent update to the Intel Chipset Manager.
So, as far as I can tell, I’m up-to-date with Dell.

There is no change in rendering of my SlingPlayer. Still works on embedded displays, fails on the DataLink displays.

I looked at the Readme file on latest driver from Intel. There is no mention of a fix to display-only display devices. I did not install it. If you have information that this will 100% SOLVE my problem, I will apply. But if it’s just a hunch, I prefer to stick with what Dell provides for the time being.

Hi Steve,

No problem if you’d like to wait for the driver updates to funnel through Dell first.

The reason the most current Intel readme doesn’t mention an OpenGL fix is because it was called out on a previous driver release the first time they acknowledged the fix in version

If the issue is caused by the OpenGL version reporting bug, Intel drivers .4849 and later would be expected to resolve it. If they don’t resolve it, then the issue has another root cause and hopefully Sling would be willing to work with DisplayLink on an escalation.


Hi Steve,

We’re closing this thread due to inactivity. Please do feel free to reach out to if you would like to revisit.