No input device detected on Ubuntu 18.04

Hello. I received your product today, plugged it in on my Ubuntu machine and everything went smoothly (well, not quite). I am able to connect to my headphones and the sound quality is reasonable. However, the headphones are not listed as an input source, even though they have a microphone and have worked on a different machine running Ubuntu before. The profile is set to A2DP Sink. Changing the profile to a headset results in an error ‘failed to change profile to headset headunit’ .I have tried Blueman as well as Pulseaudio to fix this, without any luck.

Bluetoothctl output:

Device 04:88:E2:54:9E:30 (public)
Name: Powerbeats Wireless
Alias: Powerbeats Wireless
Class: 0x00240418
Icon: audio-card
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: no
UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
Modalias: usb:v290Bp1200d0110

pacmd output:

index: 4
name: <bluez_card.04_88_E2_54_9E_30>
driver: <module-bluez5-device.c>
owner module: 30
	device.description = "Powerbeats Wireless"
	device.string = "04:88:E2:54:9E:30"
	device.api = "bluez"
	device.class = "sound"
	device.bus = "bluetooth"
	device.form_factor = "headphone"
	bluez.path = "/org/bluez/hci0/dev_04_88_E2_54_9E_30"
	bluez.class = "0x240418"
	bluez.alias = "Powerbeats Wireless"
	device.icon_name = "audio-headphones-bluetooth"
	a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 40, available: yes)
	headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: no)
	off: Off (priority 0, available: yes)
active profile: <a2dp_sink>
	bluez_sink.04_88_E2_54_9E_30.a2dp_sink/#4: Powerbeats Wireless
	bluez_sink.04_88_E2_54_9E_30.a2dp_sink.monitor/#5: Monitor of Powerbeats Wireless
	headphone-output: Headphone (priority 0, latency offset 0 usec, available: yes)
	headphone-input: Bluetooth Input (priority 0, latency offset 0 usec, available: no)


Thank you for your message!

You may need to update BlueZ in addition to the other components mentioned.

I’d recommend going through the steps that we have available here after clicking ‘Click to Show Linux Information’.

I hope this helps. If you continue to encounter issues, please contact us at and include your Amazon Order ID for the adapter. We can help gather additional information.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.