No HDMI signal from USB-C docking station (used to work)


#1

Hi there!

All of a sudden, I’m having troubles connecting my monitors to my plugable USB-C docking station.

I have a HP Spectre Notebook (Win10) and used to connect 2 external moniors (also HP) via HDMI to the docking station (UD-ULTCDL) to have 3 displays in total without any problems.

Everything worked just fine until this morning. Suddenly, the first monitor wasn’t able to connect when I plugged in my laptop. I tried unplugging the HDMI and replugging it but that didn’t solve the problem. I tried unplugging it again, and the other one, which ended with me not having none external monitor working at all. I then tried unplugging everything from the docking station and replugging it: power cable first > then USB-C host cable > then HDMI cables but it didn’t work.

I also tried reinstalling the DisplayLink drivers. One monitor was back - but only briefly, unfortunately. When I touched the HDMI cables of the other monitor to make sure there was no loose contact, the one that had just restarted working, broke down again.

It seems as if the monitor on the HDMI 4k port randomly and briefly displays the screen (but then stops again) whilst the other one on the HDMI 2k port does nothing alltogether.

The monitors don’t seem to be broken as they display a “input signal not found” message when I plug in the docking station. Also, they work perfectly when plugged into the laptop directly.

Same goes for the docking station which is charging the laptop correctly when plugged in.

Do you have any idea how I can get them working again?

Thanks a lot in advance!


#2

Hello,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

You’ve already tried a power cycle reset so I don’t expect having you do it again is going to necessarily help, but here’s our reset procedure in full just in case:

"Fully unplug the dock from all devices, power, and USB-C cable to the host computer. Wait about 30-60 seconds, then reconnect the power cable first, USB-C host cable next, and USB devices last. Sometimes a reset in this order can resolve this issue.

  1. Are you using the USB-C to USB-C cable that the dock shipped with or are you using a 3rd party cable?

  2. What ports are the monitors connected to on the back of the dock? Both “4K” and “2K” HDMI ports?

  3. We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the dock with your monitors attached to it into your computer, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer
Plugable Technologies


http://plugable.com | http://performance.plugable.com/


#4

Hi Joshua,

Thanks a lot for getting back to me so quickly!

  1. Right; I read about this and tried unplugging and replugging the docking station according to the procedure you describe.
  2. Yes, I am using the cable that was shipped with the docking station and that used to work just fine up to know.
  3. Right; both the HDMI 4K and the HDMI 2K ports are in use. For the 4K port, I randomly got a display while trying to fix the issue, but it was never stable and currently there isn’t a signal again. For the 2K, however, I didn’t seem to get a signal at all anymore.
  4. I’ll try that - thanks.

Best regards!


#5

Hello!

Thanks for the information! I’ve received the diagnostics and will take a look to see what I can find out. I’ll be back in touch again ASAP!

Best,
Josh


#6

Sorry for my delayed reply. It took a while to get through the diagnostics (since the diagnostics were in German). Apologizes!

After going through the diagnostics here is what I can see:

Betriebsystemname Microsoft Windows 10 Home
Version 10.0.17134 Build 17134
Systemmodell HP Spectre x360 Convertible 13-ac0XX
Prozessor Intel® Core™ i7-7500U CPU @ 2.70GHz, 2904 MHz, 2 Kern(e), 4 logische® Prozessor(en)
BIOS-Version/-Datum American Megatrends Inc. F.41, 29.11.2017
DisplayLink Graphics Driver 8.6.1294.0
Intel® Graphics 21.20.16.4590
Thunderbolt™ Software 16.2.52.250

The Intel graphics and Thunderbolt software are quite old, as is the DisplayLink driver (though this driver wouldn’t affect the 4K HDMI output, the others might). Let’s try getting those fully updated and see if that helps. Otherwise looking in the diags nothing else is standing out to me as an obvious cause here.

Latest Intel Graphics (you may need to uninstall the currently installed version in the Apps & features control panel first):
https://downloadmirror.intel.com/28567/a08/dch_win64_25.20.100.6577.exe

Here’s the Thunderbolt update:
https://downloadmirror.intel.com/28579/eng/TBT_WIN10_64_17.4.77.400.zip

And finally, here’s how to do a clean install of the latest DisplayLink drivers:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step.

  3. Download, extract and run the DisplayLink cleaner tool, found here --> http://www.displaylink.com/downloads/file?d=64 and ensure it displays “Cleaning Complete”
    when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 9.0 M1 DisplayLink software, found here --> https://www.displaylink.com/downloads/file?id=1300

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please reboot the system.

Thanks!
Josh


#7

[Also via e-mail]

Dear Josh,

Thanks a lot for the instructions above and for your efforts!

Unfortunately, although I followed each and every step carefully, this didn’t work either. :frowning: Still the problem persists and the monitors won’t receive a signal from the docking station (though the laptop is charging via the dock).

Any further ideas how this could be fixed?

Thanks again & best!


#8

Unfortunately, after looking through the diagnostics once more for anything that may have been missed I have to report I didn’t find any new clues. I think we may need to send you a pretested replacement docking station under warranty. I will contact you directly via email for some information to so do.

Thanks and sorry!
Josh


#9

What a pity :frowning: But thanks for providing me with another device which hopefully can fix the issue. The warranty should still be valid btw if that is relevant as I bought the docking station less than a year ago

Looking forward to your email.
Thanks again.


#10

You should have hopefully gotten my email! I sent two, once the other day, and one again just now. If you don’t receive my email please contact us directly at support@plugable.com with the following info:

Amazon Order ID # or other proof of purchase, serial # off the bottom of the dock, and the best shipping address.

Thanks!
Josh


#11

Yes, I did.
Thanks a lot for your kind support!


#12

Hi Josh, just wanted to let you know that the replacement dock arrived and works perfectly fine! Thanks a million for your help :slight_smile:


#13

Thank you so much for letting me know! If you ever need anything else we’re always happy to assist.

Best wishes!
Josh


closed #14

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.