No audio output on TBT3-UDZ

I’m running macOS 11 (Big Sur) and cannot see the audio in/out as a choice on my computer using the TBT3-UDZ


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

If you disconnect the dock completely, then reconnect it to power first, then the Thunderbolt 3 connection to the computer, and then the rest of your devices, does the sound then become detected? Also, have you tried a simple reboot of your Mac? Usually device detection issues can be resolved by these simple steps.

If these suggestions don’t help, can you say if you’re trying to use audio in/out through the front combination TRRS headphone/microphone connection for a headset? Or, are you trying to output audio through an attached display with speakers and are connecting just a microphone through the front?

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry

Senior Engineer | Product Owner
Plugable Technologies

Yes! That was the fix. I now see it as Realtek USB2.0 Audio and all works well. Thanks!

1 Like

Great news! Glad that worked. If you ever need anything else just let us know.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.