Nexus 7 4.2.2 and USB 2.0 10/100 ethernet


#1

Some other posts indicate that these should work together with no problem, but no joy here. Plugable is “dead” and checking shows no power at the circuit board. Cables ok, and Plugable works with Windows. I assume the no-power is the N7 deciding should be a sink, not a source to what is plugged in. Is there a setting somewhere that I’ve overlooked to enable ethernet thru the usb port? Thanks.


#2

Hi Bob-

Thanks for posting with your question!

Unfortunately each device maker controls these settings individually, and we’ve not found anything where Google is publishing how this is controlled. I’m surprised to hear the USB2-E100 isn’t working since it does in most cases- we have seen some power issues in the past, trying the USB2-E100 connected via a powered hub instead of directly into the nexus might be a good thing to try. Also, enabling airplane mode is a good way to make sure you’re not using WiFi or getting confusing results from it being on.

Sorry I can’t offer a more specific fix here, hope this helps, but please let me know if you’ve any other questions. I suspect this will work with some tinkering since we know it’s not a bad adapter: I’ve seen the device work with our nexus 7 in the lab.

Best wishes-

Jeff Everett
Plugable Technologies


#3

8/21/13

Hi!

I’m having the same problem. I just purchased the same product along with an OTG cable and it doesn’t recognize any usb storage devices and it doesn’t link to the internet (the lights on the USB2-E100 don’t light up).

I’ve tried airplane mode on and off and wifi mode is always off and nothing happens.

What should I do next?

Thank you!!!

Bill


#4
  • I finally got an OTG and the usb/ethernet device work fine. From reading, there seems to be a consenus that not all OTG devices are identical. I got this one thru Amazon: T & S Electronics Micro USB OTG Cable.

Regarding usb drives, I had to install Nexus Media Importer (from Play). Thumb drives work. Haven’t tried anything else.


#5

Hi Bill-

We’ve also had no problems using the USB2-E100 on our 1st Gen Nexus 7, either before or after applying the Android 4.3 update.

If you are having issues with the unit (and know it works on other devices like your laptop) double-checking whether the OTG cable is causing issues as Bob suggested is the best thing to do.

Closing thread as the USB2-E100 is confirmed to work on the 1st gen nexus 7. Please email support@plugable.com with any other questions- we’re happy to help but want to keep this thread nice and neat and easy to understand for the benefit of other users.

Best wishes-

Jeff Everett
Plugable Technoloiges


#6