New V dock isn't reading drives (but the old III is)

I just bought the USB-C SATA Hard Drive Dock to upgrade from my previous USB 3.0 SATA III. I run 4 SATA drives between 2-4tb to backup NAS and tower drives.

I was about to donate the old SATA III, when I discovered the SATA V isn’t reading any of the old drives or mounting them into disk manager. It won’t even mount them to reformat or otherwise see them. I was able to mount an older 1tb drive. First in the III, and it worked fine. It was then the first and only drive to appear in the V, but then after sitting for a few minutes disappeared. I shut down the V and mounted the 1tb into the III and it worked fine.

Could it be a defective docking station? I only upgraded to take advantage of the faster speeds and flashy new usb 3.1 ports on my tower :slight_smile: So far I have not been able to get any other drives to show in the V. I’ve tried a bunch of old SATA drives as well. Unfortunately I don’t have any new unused drives to test.

Any suggestions?


Thanks for reaching out! I’m sorry to hear your new UBSC-SATA-V isn’t working as expected, and I will be happy to assist you with this.

At this time I would like to gather some additional details from you, including some diagnostic information, and order information.

If you could please contact us directly at support@plugable.comand reference ticket #381232 we would greatly appreciate it!

Once more we’re sorry for the trouble, and I look forward to hearing from you.

Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.