new USB2 Ethernet Adaptor cannot be recognized by Windows 8.1


#1

Just purchased USB2-E1000, a Gigabit USB 2 Ethernet Adapter for my Lenovo Idealpad. Downloaded and Installed the newest 2.0.2.0 Windows 8.x driver. But, nothing happened on Windows 8.1. Power-cycle several times and still cannot detect the newly plugged USB adapter. Anyone has any experience or tip to make it work ? Thank you very much in advance. Elliott


#2

Hi Elliott,

Thank you for contacting us about your Ethernet adapter. I’m sorry it is not working for you.

We have a troubleshooting tool that helps us find out what is going on in situations like this. Please plug the adapter into your computer, connect to your network, then go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

Please send the resulting file directly to us at support@plugable.com and use “For Ticket ##43647” as the subject.

Thank you,

David
Plugable Support


#3

Hi David,

Thank you for the reply. I’ve run the debug application and email the zip file, generated while this Ethernet Adapter connected on the Windows 8.1 laptop, to support@plugable.com. Hope can hear from them soon.

In addition, I plug the adapter to a Windows XP computer. Same result, … nothing happened. No USB device detection alert, nothing detected even after installing the drivers. Not sure if I got a dead-on-arrival adapter. i will wait for Plugable’s support to decide.

Thank you.

Elliott


#4

Hi Elliot,

Thank you for sending that. I will check the email to see if it has come in, and let you know what I discover when it does.

David


#5

David,

Could you please advise the progress of the bug detect file? I would like to have the issue resolved as soon as possible. If it’s indeed defective, I would like to arrange a RMA to have it replaced. If it’s not, please advise how can I make it work.

Thank you for your attention and helps.

Elliott


#6