New product USB3-VGA is not detecting a monitor.


#1

New product USB3-VGA is not detecting a monitor. In troubleshooting I tried it with a different VGA monitor, and it works fine…So the adapter appears good. I also tried reinstalling the drivers. This had no affect. Service is running (Under x64 Windows 7). No matter what I do the tray manager won’t come up and the monitor won’t come on. Device manager sees the device, no conflicts. I tried an older product - which I hoped to be replacing (UGA-2K-A) and it works fine on any monitor. I also tried the new device on a different machine (Laptop with x64 Windows 7) and can repeat the results, so it doesn’t appear to be machine specific. I bought two of the USB3-VGA adapters and have opened one. I really hope I don’t have to RMA with Amazon because this model can’t detect my monitor. Any thoughts or suggestions welcome. Thanks.


#2

Hi Tom,

Thanks for contacting us - and thanks for the pre-troubleshooting and great info about the specific circumstances where the problem happens!

It sounds like an EDID problem. When a graphics adapter first starts, it communicates with the monitor through one of the lines to get a 128 byte block of data that communicates the monitor’s name, serial, preferred / native mode, and backup modes. Without this information, the DisplayLink driver doesn’t recognize a monitor as present.

The protocol to query EDID is kind of primitive and prone to error - VGA cable length and other factors can definitely affect it.

A quick question and suggestion for next thing to try:

Using the USB 3.0 VGA adapter, If you swap the VGA cables between the monitor that worked and the one that failed, does the problem follow the cable or the monitor?

Thanks for letting us know. From that, we’ll be able to figure out next steps.

Thanks again!
Bernie


#3

Hi Bernie. I did think to swap the VGA cable, however it is a proprietary type that only connects to this monitor. The monitor I’m trying to connect is a 8 inch Lilliput FA801-NP/C. More info from the vendor is here - http://www.lilliputuk.com/monitors/vg…The end that connects to the monitor looks like a PS2 connector. Why the vendor choose to do this I’m guessing is because of space reasons.

I have two of these monitors and both work fine if I connect via a UGA-2K-A or a standard VGA port on the back of any desktop video card. No crazy refresh rates, resolutions, or polarity.

I did try to view logs in C:\Program Files\DisplayLink Core Software\Debug but these appear to use some form of basic encryption and are unreadable.

Thanks, Tom


#4

Hi Tom,

Thanks for the quick reply! This is interesting - the Lilliput has a native resolution of 800x600 – that low mode made create some special issues.

Would you be able to run DisplayLink’s support tool, and email the resulting .zip to support@plugable.com? Here’s how:
http://plugable.com/support/tools/dis…

That may give us extra detail on what’s going on. But there is a chance that the USB 3.0 products may default to or require a higher resolution that the lilliputs have. If we do hit any kind of limitation like that, we would not leave you hanging - we’d get you an exchange to get you hardware that does what you need. Just email support@plugable.com for any requests.

Thanks for sending that .zip, and we’ll check if it provides any definitive conclusions.

Thanks again!
Bernie


#5

Absolutely. The logs are on their way.

Thanks,
Tom


#6

To others who are interested:

It turns out that the Liliput monitor does not report EDID, which is required for DisplayLink USB graphics to work.


#7