Need tech support for a Plugable UGA-2K-A USB 2.0 to VGA/DVI/HDMI Adapter


#1

I ordered the Plugable UGA-2K-A USB 2.0 to VGA/DVI/HDMI Adapter for Multiple Monitors up to 2048x1152 / 1920x1200 Each (DisplayLink DL-195 Chipset) from Amazon on 9 December and promptly received it the next business day. I plugged it in, downloaded the Mac driver (operating a MacBook Pro 13" using OS X v.10.6.8) and it worked right away. For ~ a week and a half I was experiencing dual screen nirvana at home. I even left a really nice review on Amazon for this product.

Left for vacation on 17 December, undocked my MacBook and took it with me. Returned today, 26 December, and plugged the MacBook in ready to get to business, and cannot get the UGA adapter to work. I’ve swapped USB cables, changed USB ports, restarted, downloaded software updates, and for some reason it does not want to work. The green light flashes for a millisecond before going dark. I’ve tried finessing the cable, but to no avail.

Please help. I do a ton of spreadsheet and document work side-by-side, and have come to rely on large screen dual displays to maximize efficiency.


#2

Hi John,

Thanks for posting! I’m sorry to know about the trouble you are having with the Plugable UGA-2K-A. We will get you up and running.

Could you run the DisplayLink support tool (instructions here: http://plugable.com/support/displayli… ) and email the .zip to support@plugable.com. along with a link to this thread and your Amazon Order ID?

This would give us a better insight as to what is going on. Once we analyze it, we can figure out the next steps.

Thanks for your patience while we figure this out!

Regards,
Roze


#3