My USB to Ethernet adaptor isn't working on my macbook


#1

So I just recently bought a USB2-E100 USB 2.0 10/100 ethernet adapter and am trying to get it set up. I am using a macbook pro running OS X Mountain Lion v10.8.4. I’ve installed the most recent mac driver from the Plugable website and under the “Ethernet Cards” and “USB” sections of my system information, everything looks as it should (similar to how it looks in the PDF manual).

My problem is that when i go to my system preferences and try to set up the USB Ethernet connection, no connection seems to be found. I know the ethernet chord I’m using works because i have it hooked up to my desktop and it works just fine. Neither of the two lights on the actual adaptor are lighting up either (not sure if that means anything?).

Any ideas?


#2

Hi Sam,

Thanks for posting! Installation of the driver is actually only required for earlier versions of OS X (before 10.8). But it doesn’t hurt either.

So probably something else is happening with hardware or configuration.

In terms of configuration, OS X should automatically populate a “USB Ethernet” network type in the network control panel. On my machine, I don’t have an adapter connected currently, so it’s marked red:

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/950064/usb-ethernet-mac-no-connection_inline.jpg?1378064915)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/950064/usb-ethernet-mac-no-connection.jpg?1378064915)

Do you have have a “USB Ethernet” entry and if so is it red or green?

And if not, could you hit the “+” button and does USB come up as one of the interface choices?

With that info, we’ll be able to figure out next steps. Thanks for your patience!
Bernie


#3

Bernie,

Yes, I have the option that says “USB Ethernet” and it is red and says “Not Connected.” I also can use the “+” button to make a new network option and that works fine too.


#4

Hi Sam,

Thanks for the quick reply!

Have you used this Ethernet network cable connection before? We’d like to make sure it’s a good connection back to a router, and that that router allows additional devices to be on the network (some routers from certain ISPs are set to only give out an IP address to one specific MAC address, or certain particular MAC addresses).

Assuming you’re confident in the network connection …

Let’s try first to uninstall the ASIX driver and use the driver built into 10.8.4 instead. Just download the Mac driver which is the first one of the “Drivers” section on:
http://www.asix.com.tw/products.php?o…

When you open that .zip, there’ll be a .dmg file inside. When you open the .dmg file, you’ll see a .pkg install script and an uninstall script.

Please go ahead and run the uninstall script and reboot the Mac.

Then go to the network control panel, select “USB Ethernet” and hit the minus key to delete that configuration, then hit the “+” key to create a fresh USB Ethernet configuration.

If still not working, do you have any other computers around to try the USB Ethernet adapter on, to confirm the hardware is good?

Just let us know if you aren’t able to confirm the USB Ethernet adapter works on another machine – we’ll find another way.

Thanks for your patience!
Bernie


#5

Bernie,

Ok, so I am testing it out now with two other computers, one desktop and one laptop both using Windows 7. I’m pretty sure the ethernet connection is not the problem because it works with both of them whenever I directly plug it in.

I also downloaded the driver again to my macbook from the link you gave me and made sure the driver was uninstalled.

After I uninstalled it, I tried removing the existing “USB Ethernet” configurations and creating a new one, but still no luck with that either.

I then tried using the adaptor on both of my other computers, once without the driver installed and once with the windows driver, and both of those didn’t see to be able to connect to a network either. So I’m starting to suspect that the problem is something to do with the actual adaptor.

Neither of the two LED lights came on at anytime on the adaptor throughout this whole process also (still not sure if that’s even significant).

PS. Thanks for the continued help and the patience too, much appreciated!


#6

Hi Sam,

Thanks for running through those steps. I’m sorry, it is looking like a bad unit. We’ll get you fixed up right away. Just email your Amazon order # to support@plugable.com and include a link to this thread. We’ll get that out right after Labor Day. Thanks for your patience!

Bernie


#7

I got the new adaptor and it works perfectly! I plugged it in and it worked right away.

Just thought I’d give a follow up in case anyone else was searching and had this same problem.

Thanks for the help!


#8

Sam,

Fantastic! Thanks for the update. Glad to know that the replacement is up and running. If you ever need any help or information regarding any of our products, please do feel free to shoot us an email at support@plugable.com. We are here to help!

Regards,
Roze


#9