My USB 3.0 HDD docking station no longer reads HDDs.


#1

I bought the Plugable USB 3.0 HDD docking in June 2012 and it no longer works. I tried switching USB 3.0 cables and used three different HDDs, but the docking station doesn’t appear to be sensing anything anymore. The HDD would still power up and spin, the LED of the station goes on but turns off after about 30 seconds.
I am using OSX Mountain Lion with a Macbook Air 2012 model.


#2

Hi Howard-

Thanks for posting, I’m sorry to hear your U3 seems to have stopped recognizing disks.

One quick troubleshooting test we’d like to try is to see if you’re able to get a connection over a USB 2.0 cable. Please let us know if that works, and if not shoot an email to support@plugable.com with your Amazon Order ID and we’ll get you taken care of.

Best wishes and Happy New Year!

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies


#3

Hi Jeff,
Happy New Year to you too!

I tested a couple of HDDs with a USB 2.0 cable and it appears to be working. Please advise. Thank you!


#4

Hi Howard-

When USB 2 works and USB 3 does not, we may have issues with either the USB 3 Host Controller Driver or Firmware, or a faulty USB 3 cable. If you have another USB 3 cable to test against that possibility, please do so and let me know if it helps.

As to the possibility of the firmware or driver update, I’ll need to know a bit more about your system to recommend the appropriate update. If you can please reply with the output from DisplayLink’s support tool, I’ll be able to recommend any relevant updates her. Please note that the support tool was designed for another purpose, so please disregard any compatibility messages, however it’s a very convenient way to get the needed info. Here is a link with instructions on use and download of the support tool: http://plugable.com/support/tools/dis…

Best wishes-

JE


#5

Hi again Howard-

I forgot to explain, please send the output from the tool- attention Jeff- to support@plugable.com, and include a link to this thread. This will keep your system details private.

Best-

JE


#6

Hi Jeff,

I do happen to have another USB 3.0 cable and it yielded the same result as the other USB 3.0: no HDD recognized.

I looked at my system profile and got this about the USB bus:
USB 3.0 SuperSpeed Bus:

Host Controller Location: Built-in USB
Host Controller Driver: AppleUSBXHCI
PCI Device ID: 0x1e31
PCI Revision ID: 0x0004
PCI Vendor ID: 0x8086
Bus Number: 0x14

MassStorage Device:

Product ID: 0x5002
Vendor ID: 0x1759 (LucidPort Technology, Inc.)
Version: 25.80
Serial Number: 5QG2DFF0
Speed: Up to 5 Gb/sec
Manufacturer: USB 3.0
Location ID: 0x14a00000 / 1
Current Available (mA): 900
Current Required (mA): 0

If you need more info than this, than I’ll install that DisplayLink support tool.


#7

Hi again Howard.

Those details are perfect, thanks for verifying, and no need for the support tool’s output as a result.

Can you please email support@plugable.com again with your Amazon Order ID, the serial number from the defective unit, and your shipping address?

Since the driver updates I was mentioning all apply only to Windows- since these don’t apply to Macs we’ll need to get you an updated unit if the USB 3 cable isn’t the culprit. We’ve found (interestingly) that U3’s that work normally on Windows systems and some Macs won’t work on others. We’ll send out a pre-tested replacement.

Best-

Jeff


#8