My USB 2.0 adapter never worked till now

I purchased this USB 2.0 adapter and I have not been able to make it work till now. I tried it on my Surface Pro, my latest Dell. I installed the drivers separately too. It is yet to work. Not sure what I am missing.


Thanks for reaching out on our forums, I’d like to get some more information so that I can help.

Could you tell me a bit more about what product you’re looking for assistance with? You can provide a link to the Amazon product page for it, or provide the SKU (for example USB-BT4LE or UGA-165).

Once I have more information, I can better assist.


USB 2.0 Fast Ethernet. 10/100Mbps. Model: USB2-E100. I have MAC number too. I could not upload the picture in this message since I am a new user.


Thanks for reaching out to us. It looks like you have one of our USB2-E100 adapters. I’m sorry for the trouble here, and I’d be glad to help you.

This would be best handled via direct email so I can get a diagnostic of a computer with the adapter plugged in to see what may be going on under the hood.

Once everything is set up, please download and run our diagnostic from this link:

A folder with the results will be placed on your desktop after running the tool. You’ll need to reach out to us directly at: with the diagnostics for us to review.

Thank you. If you would, please also include your Amazon order number.

Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.