My UGA Display Adapter won't adapt!


#1

Purchased UGA-2K-A USB 2.0 Multi-Display Adapter through Amazon.com. Connected the adapter and loaded the driver as per instructions. Now have issues with a pop up notification when my screen saver activates or I try to load a new application. “C:\Windows\System32\dlumd32.dll is either not designed to run on Windows or it contains an error. Try to reinstall or contact your administrator.” The DisplayLink Core cannot be uninstalled. Assistance and correction instructions are appreciated.

jhf3@sbcglobal.net


#2

Hi John - Thanks for posting and sorry you’re hitting a software issue with the DisplayLink drivers. Let’s get it solved.

A few quick questions:

  1. What WIndows version are you running? (XP, Vista, 7)? 32 or 64-bit?
  2. As you’re getting these errors, does the screen attached to the UGA-2K-A work, and do the apps work after you go past the error?
  3. From the text, I assume this problem happened right from the get-go, is that right?
  4. For the DisplayLink drivers, did you download version 5.6 from http://displaylink.com/support/downlo…, or use the version automatically downloaded by WIndows 7? If you didn’t go to displaylink.com, can you give that a quick try and let us know if it reports any errors during install.

Thanks for these quick double checks. We haven’t had a report of this problem yet, but it’s clearly software, and we’ll work to figure it out.

Thanks for your patience,
Bernie


#3

For the benefit of others: The system didn’t have the latest DisplayLink drivers yet, and the older drivers were having some kind of conflict on his system.

By uninstalling with the DisplayLink cleaner utility http://www.displaylink.com/support/ti…

And then installing the latest DisplayLink drivers (5.6 from http://www.displaylink.com/support/do…)

All appears well now. Glad to have John up and running!


#4