My UD 3900 is not recognizing the ethernet or the HDMI ports

I am not able to connect with ethernet using the ethernet port in the UD-3900 unit to my HP Envy laptop. Also it does not recognized the HDMI connector for my second screen. Please help me.

Hi Alejandra,

Thanks for reaching out to Plugable support! I’d be happy to help with that docking station.

The first steps we’ll want to take is to make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.

  2. Uninstall any and all software with ’ DisplayLink ’ in the title that is present from within the Control Panel -> Programs and Features . Don’t worry if these entries are not present or if the process does not work, just move onto the next step

  3. Download, extract and run the DisplayLink cleaner tool (https://www.displaylink.com/downloads/file?d=64)

  4. Once the Cleaner has been run, reboot (even if not prompted to)

  5. Now download and install the 10.0 M0 DisplayLink software (https://www.displaylink.com/downloads/windows)

  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

Hopefully that will get things working for you.

Thank you for giving us a chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.