My Plugable’s USB-C Triple 4K Docking Station stopped working completely

My Plugable’s USB-C Triple 4K Docking Station was working perfectly fine. Then one morning I plugged my laptop in and nothing happened.

I unplugged everything and let it reset and still nothing. I also ensured all my drivers were up to date and nothing working. The docking station’s blue light is on but its not sending power to the laptop or registering any plugged in device. I am using the factory USB-C cord.

Hi,

Thanks for contacting us! I am sorry this is not working as expected.

Based on your description of the behavior, our first step is to get some additional information from your system.

If you would, please keep the dock connected to the computer with monitor(s) connected to the docking station (even though one may not be working) and attach the output of our diagnostic utility PlugDebug ( http://plugable.com/support/plugdebug ) to an email to ‘support@plugable.com’ with the subject line ‘Ticket #380968 - Attention Pat’ as this will allow us to examine some log files from your system to help determine the next steps.

Additionally, please let me know the specific model of docking station, this can be found on the Plugable label on the bottom of the docking station as the last section in the web address starting with “ud-” for our triple display docking stations. Please also include the docking station’s serial number in your reply email, this can also be found on the bottom of the docking station in the format “K##-#######” or “####A#####” either on a barcode label, or just below the “CE” and “FCC” marks, depending on the specific model of docking station.

Thank you, I look forward to your reply email and we can proceed from here.

Pat
Plugable Technology
support@plugable.com

I just emailed you as instructed and my model number is UD-695OPDZ