My Multi-Display Adapter just doesn't make it, please help me...


#1

Hello my friends:

I have the pleasure of being your customer, I recently got the “Plugable USB 3.0 Multi-Display Adapter” and I have a problem installing it, because my system says that it finds a “Compatibility problem” and constantly says that it might cause damage to my computer and to avoid it needs to be restarted. Whenever I restart the computer it appears the same message.

The system I have is the following:

  • Processor Intel ®_ core ™ i3-2100 CPU@3.10 GHz

  • Installed Memory RAM 16.0 GB

  • System type is 64-bit Operating System

  • No pen or touch input.

  • Windows 7 Professional, Service Pack 1

  • Card name: NVIDIA GeForce 7300 GS

Manufacturer: NVIDIA

Chip type: GeForce 7300 GS

DAC type: Integrated RAMDAC

  • Two HP 2709m monitors wide screen which I have using them for a long time with that Graphic Card and working fine.

  • I want to add a Samsung C230 Series S27C230B 27-Inch Screen LED-Lit Monitor and I got the “Plugable USB 3.0 Multi-Display Adapter” for this third monitor but I can not use it…

Please help me, I look forward to your e-mail with the solution and I thank you in advance for it.

Greetings,

Antonio Machado

elavefenix@hotmail.com


#2

Hi Antonio,

Thanks for reaching out to us, I’d be more than happy to assist you with your Plugable display adapter. In order to figure out exactly what is going on, we’ll need some additional information.

In order to figure out what exactly is going on and why the adapter is not working properly, we’ll want to collect a bit of additional information.

First, let’s gather some log files produced by our tool Plugdebug. Can you please go to this site, follow the prompts there, and send us the resulting .zip file at support@plugable.com.
www.plugable.com/plugdebug

Once we have those logs, we’ll have a better idea of what to do next.

Regards,

Stephen
Plugable Technologies


#3