My laptop connects to USB 3.0 dock inconsistently


#1

I hgave an Asus Ultrabook and bought a Pluggable USB 3.0 instead of the Kensington. The problem is that when I plug in the laptop to the dock, it connects sometimes but not every time. When it doesn’t, it’s maddening to try to get it to connect. Unplugging the laptop, unpluging power to the dock, restarting the laptop…there is no consistent successful solution. Has anyone else had this issue?


#2

Hi Jim,

Thanks for posting! I’m sorry your Plugable docking station is not working as expected and I would be happy to help.

Based on your description of the behavior there are a few quick things to check, and the first is if connecting the dock to a different USB port of the Asus laptop helps. This will help us isolate if the problem is specific to one USB port.

If switching the port does not help (or if the system only has one USB port) the next step is to see if the USB cable being used is the issue by swapping it with a new one. If you do not have another USB 3.0 cable like the one we include in the box with the dock, you can use a USB 2.0 cable (like you would use with a USB printer) temporarily to test. Even though the end of the USB 2.0 cable that plugs into the dock is physically different than the USB 3.0 version, it will work.

Please just let us know the results when you have a moment, and we will determine the next steps from there. Thank you in advance for your patience and the chance to help!

Bob
Plugable Technologies
www.plugable.com/support


#3