My Hub has lost ports 2, 3 and 4!


#1

Hey plugable,

I have been using my USB3-HUB7-81X on my desktop for a few months now.

But as the devices I have used have always been plugged in, I have never used ports 2, 3 and 4.

Today I tried to move one of the devices to Port 2 and the device didn’t connect and no blue light. I tried ports 3 and 4 and they also don’t light up blue.

I tried putting the hub on another machine, and same problem with ports 2, 3 and 4.

I reconnected the hub to my current laptop and grabbed the firmware upgrade tool from your website. which shows what chipset and firmware I have. A screen capture is attached.

I think there are 2 entries because I disconnected and reconnected the hub from my pc.

What should I do next?

Cheers
Ben

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1271246/usbhubfwtool_inline.png?1441424112)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1271246/usbhubfwtool.png?1441424112)


#2

Hello Ben,

I am sorry to hear this.

Did you hit start upgrade and nothing happened thereafter?

In the meantime, can you please perform a USB reset to see if we can reproduce the symptoms once again?:

  1. Disconnect USB hub from computer and power and wait for 120 seconds (also disconnect all USB peripherals from the USB hub itself)
  2. Connect USB hub into power and wait for another 10 seconds
  3. Connect USB hub into your computer and test all 7 ports with a simple USB device such as a wired mouse or keyboard
  4. Now connect your usual peripherals to verify functionality.

If end up with the same symptoms please reply just to support@plugable.com with the following information:

  1. Amazon order ID.
  2. Serial number from sticker on bottom of unit.
  3. Shipping address.

I will get started on sending you a pretested replacement unit to rule out hardware failure.

Kind regards,
Patric
Plugable Technologies


#3

If you could please hide my shipping details that would be much appreciated.


#4

Please contact us directly at support@plugable.com. I will close this post in the meantime.


#5