My display adapter suddenly stopped working - Mac


#1

Recently my Plugable USB 2.0 UGS-2K-A adapter suddenly stopped working, not sure what’s happening as even the green LED in the device is off. I upgraded the drivers using the latest 1.8a1 version from DisplayLink but it didn’t help either.

Here’s the information gathered from System Information:
USB Display Adapter:
Product ID: 0x8060
Vendor ID: 0x17e9 (DisplayLink (UK) Ltd.)
Version: 0.17
Speed: Up to 480 Mb/sec
Manufacturer: DisplayLink
Location ID: 0xfd120000 / 4
Current Available (mA): 500
Current Required (mA): Unknown (Device has not been configured)

Here’s my Mac info:
MacBook Pro
15-inch, Early 2011
Processor 2 GHz Intel Core i7
Memory 8 GB 1333 MHz DDR3
Graphics AMD Radeon HD 6490M 256 MB
Software Mac OS X Lion 10.7.3 (11D50)

I found the following on DisplayLink’s forum:

The problem with Product ID = 0x8060 is not a very common problem however our customers report it from time to time. DisplayLink cannot however be blamed for this problem as the chip in the device is not booting up properly and it means that the device is faulty. PID = 0x8060 shows that it has booted from the bootrom (rather than the EEPROM). This means it will not enable any video outputs.

We recommend unplugging all cables from the adapter, then connecting USB and then connecting the DVI/HDMI cable. This might resolve the problem. If it won’t, then the manufacturer should be contacted for the replacement.

I’ve tried the recommended solution but it’s still the same.


#2

Hi Thiago,

Thanks for posting here! I’m sorry to know that the Plugable UGA-2K-A is not working. I apologize for the frustration caused by it.

Please shoot us an email at support@plugable.com with your Amazon Order ID and the serial no (given at the back) of the device along with a link to this thread. We will take care of the issue and get you up and running at the earliest.

Regards,
Roze


#3