My 7 port USB 3.0 hub does not work at all.


#1

Everything is plugged in nice and tight and the usb is a working one, but no. When I twist the power cord into the hub lights occasionally come on- 4 and 6 brightly, and 3 weakly. It’s very strange. Lights coming on corresponds to the blinking green light on the adaptor. Now, nothing works at all. The adaptor is cool again. No idea what is wrong. It could be a problem with the adaptor.
Plugable USB3-HUB7-81X Seven-Port USB 3.0 Hub with Four-Amp Power Adapter


#2

Hi Olivia-

Thanks for posting with your issue and sorry to hear about the frustration caused by the hub-- I’ll be happy to help.

Any flashing on the power supply’s LED indicates either a problem with the power supply or that the power supply is shutting off due to having much more than the rated maximum of 4 amps of devices. So something power related is likely to be the cause of the trouble. One thing to watch out for is having mixed up the power supply from another device. Ours is a 5 volt 4 Amp one as shown here:
!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1058837/usb3-hub7-81xpowersupply_inline.jpg?1400786102)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1058837/usb3-hub7-81xpowersupply.jpg?1400786102)

The 4 amp power supply is fine if you’re using a “normal” mix of devices including one or two low or self-powered devices-- things like keyboards, mice, printers, scanners, external hard drives with their own power supply, etc.

If you’re using several high power devices-- bus powered external hard drives or things like Apple’s SuperDrive that are designed to require much more than USB standard power levels, this can cause the power supply’s over current protection to kick in.

If having too many high-power devices doesn’t seem likely, taking a quick look at the support logs from your system can help rule out any other common issues quickly. If you can please run our support tool, PlugDebug, and send the .zip it creates on your desktop to support@plugable.com I’ll be able to recommend our next steps.

Instructions to download and use PlugDeubg are at

http://plugable.com/support/plugdebug

Thanks for your patience as we work to help!

Best wishes-

Jeff Everett
Plugable Technologies


#3

I use the right adapter, the one in that came in the box, and have zero devices plugged in, but it flashes lights and does not work properly.


#4

This is a great conversation that’s separate from the main topic, so I created a new topic to continue the discussion. Please reference the new topic here: My 7 port USB 3.0 hub does not work at all


#5