Multiple VLANs on USB3-E1000


#1

I recently switched to a new laptop instead of a desktop, but still needed to use it to manage multiple networks and VLANs. So I bought myself a couple of the USB3-E1000 adapters and used the same approach to this as on my desktop, by installing Hyper-V and adding a virtual switch bound to an adapter. Then I should be able to add multiple virtual adapters and configure each with a VLAN ID like this:
Add-VMNetworkAdapter -ManagementOS -Name AdminNet -SwitchName “VMSwitch”
Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName AdminNet -Access -VlanID 100

When I do this on the the USB3-E1000, it fails to allow any vlan tagged traffic through. This has always worked in the past on other adapters but doesn’t seem to be able to work on ASIX AX88179 based adapters (I have another from Startech and that displays the same symptoms). It only seems to want to work with the same VLAN ID that is set in the adapter properties in device manager.

I replaced the adapter in use by the virtual switch with an old Anker USB3 adapter I have which uses a Realtek driver, and that instantly worked across all the virtual adapters, so I know the config is working as expected just not the USB3-E1000.

Is there any way to configure the USB-E1000 to work with virtual adapters on different VLAN IDs?


#2

Hello Martin,

Thank you for your question.

In the ASIX FAQ it mentions the need to set “Packet Priority & VLAN” to disabled for VLAN tagged packets to appear in WireShark. The adapter itself may filter VLAN packets when this parameter is configured as enabled before Hyper-V can check for a VLAN tag.

If that doesn’t seem to help, this may be something that ASIX would need to address at the driver level, and it may be worth contacting them directly for further assistance. Their support contact page can be found at http://www.asix.com.tw/request.php

I hope this helps.

Andy
Plugable Support


#3

That setting has not made any difference unfortunately. Is there a reason I should need to contact ASIX directly? Should this not come from you?


#4

In fact, in addition to my last point, I have in fact just tried to submit the problem on the form on the link you sent, and it fails every time (‘connection reset’ error on submitting the form).

Please can I ask you to escalate this and contact your supplier directly.


#5

Hello Martin,

I am sorry that the contact form did not work. It has in the past. I have contacted ASIX on your behalf.

They have some additional questions:

  1. Which OS are you testing under?
  2. Which revision of the AX88179 driver are you using?
  3. Does this issue only happen in virtualized Hyper-V operating systems? Can you reproduce this issue under a native Windows system?
  4. Please try to simplify your test environment and test conditions, and provide additional documentation regarding the enviornment to help them to isolate the issue.
  5. Please provide us more details about how to reproduce the issue so ASIX can do more testing to isolate the issue faster.
  6. Any other comments?

I look forward to hearing back. If you would prefer not to provide information regarding your environment in a public form such as this, please send the information to support@plugable.com with the subject line “For Ticket #199513”.

Thank you,

Andy
Plugable Support


#6

Thanks Andy, here’s the answers to the questions:

  1. Windows 10 Pro 1703, 64-bit, build 15063.674
  2. Driver version 1.18.3.0 (date 28/09/2017) 64-bit
  3. The issue is ONLY in a native Windows environment, there are no virtual machines involved here at all. You install Hyper-V in order to configure VLAN’s on the native OS, this is widely documented on the internet
  4. There is no simplifying to do here. As I said before, this works on another USB adapter, so the config is not the problem
  5. Test condition - clean install of Windows 10 Pro, install Hyper-V, plug in USB adapter and install latest driver, Make a note of the adapter name, e.g. ‘USBEthernet’. Run the following command in powershell to create a virtual switch:
    New-VMSwitch -Name VLANSwitch -NetAdapterName ‘USBEthernet’ -AllowManagementOS $true
    (The last setting is optional, you can set it to false if you want, it makes no difference to the issue)
    Then run the following command to create a virtual adapter on VLAN ID 100:
    Add-VMNetworkAdapter -ManagementOS -Name AdminNet -SwitchName VLANSwitch
    Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName AdminNet -Access -VlanID 100
    If you don’t have DHCP running on that VLAN then manually set the IP address.
    Make sure you are connected to a switch with the port enabled for the VLAN Tag and there is another device on the network also on that VLAN. Try to ping it (after you have ensured that pings are not blocked on the device’s firewall). You will probably find that you CAN talk to anything on the default vlan (PVID) for that port.
  6. Disabling the Packet Priority and VLAN makes no difference. If you manually set the VLAN in the Driver > Advanced settings to match what you want, then it will start working on the virtual port, but stops working on the default vlan for the port. Technically you can add multiple virtual adapters, each with a different VLAN ID, and it should work with all of them at the same time - as it does with my Realtek USB adapter.

Hope this helps and don’t hesitate to ask for any more info (They can contact me directly if they want).


#7

I have the same question, how to make it work with multiple VLANs.
Which Realtek USB3 adapter are you using?


#8

Hello Trey,

Martin is still working with ASIX on demonstrating the issue that is occurring. Hopefully more information will be available soon.


#9

As an update, I have just got the Asix support team to be able to recreate the setup and they have been able to replicate the problem. They are now going to look at fixing it in the next release of the driver.

For info, the Realtek is an 8153 based USB adapter


#10

Thanks!


#11

Update: This issue is resolved in the latest drivers from ASIX (version 1.18.4.0)

http://www.asix.com.tw/download.php?s…


#12