Multiple UGA-2K UNits Not Working Properly


#1

I have just replaced my ASUS G71 with an ASUS G73S. It has an nvidia GEFORCE GTX460M with 1.5 GB of memory. I have 2 UGA-2K units, each one of which connects to a Toshiba 42" flat screen display. Everything worked flawlessly with the G71. With the new setup, the only way I can get the display to extend to the 2nd Toshiba is if I also run an HDMI cable from the G73 to a different HDMI port on the Toshiba. Even then, the display continuously flashes. I have a green led on each of the UGA devices, and I have no warnings showing up in the Device Manager. I have uninstalled and reinstalled the DisplayLink software. I have tried rebooting and power off resets, but nothing changes.I have tried swapping USB ports,cables, etc., and my problem still exists. Got any ideas??


#2

Hi Gary,

Thanks for posting! Sorry the drivers are having trouble on the G73S!

Since the adapters were working on the G71, it’s definitely a software/driver issue. We we should be able to get it solved.

The most likely culprit in a conflict between the nVidia and DisplayLink drivers. So let’s get them both updated to the latest version.

  1. If you go to http://www.nvidia.com/Download/index… and choose “option 2” to automatically find the best nVidia drivers, are any offered (often with laptops, they won’t - they’ll force you to go to Asus)

  2. When you’ve been installing the DisplayLink driver, have you been downloading the latest (currently 5.6) from http://displaylink.com/support/downlo… ? If not, give that a go.

If #1 offers no upgrades, or it’s still not working, we’ll want to know exactly what nvidia driver you’re running. Could you run Windows’ msinfo32 program, and select Components->Display and cut/paste that info here?

Thanks for your patience - we’ll get the problem figured out!

Bernie


#3

Bernie:
Thanks for the help.
FYI, I have already installed DisplayLink 5.6 - it made no difference. I have downloaded the latest nvidia driver, and I will test it here shortly (after I make sure I’m not going to roach everything by installing the new driver). I’m also pasting here the data from the System Information program:
Name NVIDIA GeForce GTX 460M
PNP Device ID PCI\VEN_10DE&DEV_0DD1&SUBSYS_20481043&REV_A1\4&35245E04&0&0008
Adapter Type GeForce GTX 460M, NVIDIA compatible
Adapter Description NVIDIA GeForce GTX 460M
Adapter RAM 1.50 GB (1,610,612,736 bytes)
Installed Drivers nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver Version 8.17.12.6114
INF File oem13.inf (Section084 section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 1920 x 1080 x 60 hertz
Bits/Pixel 32
Memory Address 0xF2000000-0xF40FFFFF
Memory Address 0xE0000000-0xFEAFFFFF
Memory Address 0xE8000000-0xE9FFFFFF
I/O Port 0x0000D000-0x0000DFFF
IRQ Channel IRQ 16
I/O Port 0x000003B0-0x000003BB
I/O Port 0x000003C0-0x000003DF
Memory Address 0xA0000-0xBFFFF
Driver c:\windows\system32\drivers\nvlddmkm.sys (8.17.12.6114, 11.94 MB (12,521,448 bytes), 10/29/2010 2:54 AM)
I’ll let you know what happens after I update the nvidia driver.

Gary


#4

So I have now tried the updated driver from nvidia. Nothing changed. I restarted the G73 after the driver update, and still no change. Do you think it would be worthwhile to unionstall and reinstall the DisplayLink software now? BY the way, the attached image shows the current nvidia driver versions.!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0uJk8NxBF3ejaNDgDsi6KV_P4AL3qXqkYd4b-bZtY8zH7afvaGS02u3lx-P-Pv8Nmw==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/455003/nvidia_drivers.png)


#5

Hi Gary,

Sorry for the slow reply!!

Yes, it’s worth a quick reinstall of DisplayLink’s driver, but only as a double-check – I think whatever is happening here on the ASUS G73S (when things were fine on the ASUS G71) is something tricky and problematic.

I think at this point (after the quick re-install), we better get full logs of the G73S system (with the adapters attached, and attached to their monitors), to see if the details can show us what’s going wrong.

Can you run the steps at http://plugable.com/support/displayli… and email the resulting .zip file to support@plugable.com?

Again, my apologies this problem on the G73S is turning out to not have a quick answer!
Bernie


#6

The steps you have requested have been performed, and I have emailed the zipped support file.

Gary


#7

Hi Gary,

Thanks for sending those logs!

You’re running a slightly older version of the DisplayLink drivers. Just to get to a known quantity, I’d recommend installing the latest (5.6) from http://displaylink.com/support/downlo…

But I’m not hopeful that alone will help, because the logs show a very strange thing - the setupapi logs from Windows are showing that the displaylink drivers installed fine and that the hardware was seen by windows.

But there are no DisplayLink logs - there should have been a file called DisplayLinkManager.log in the .zip that is always generated when the main DisplayLink Manager service is running. It’s like the DisplayLink software has never run at all.

To try to figure out where things are going south …

Could you check if DisplayLink Core Software appears to be installed in Windows’ Programs and Features control panel?

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0uHD8h2PlGaKQOAbhDwKAQ2me2UshjMmSGlosDxa4tIrKAawoZUP38R4LrJETV7G2Nff-Q8qZbq0c4qC2u-BLa_I5D07ScT4DR8J0hJN4EsY.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/469679/win7-programs-and-features-displaylink.PNG)

And if it is, can you double-check that the DisplayLinkManager service has been started in the Windows 7 “Services” tool?

!](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0mdrzqwX-Xp4xlcE22a3Ccee1Usn6KYPqtA_NQeE5d74mFz-1efTg1Toffd3dujIB8Mrs0k3ev2UWCtB5svY_y0=.PNG)](http://s3.amazonaws.com/satisfaction-production/s3_images/469681/win7-services-displaylinkmanager.PNG)

Thanks for letting us know, and thanks for your patience.

Something big (and therefore hopefully something simple!) is going wrong here on the G73, since all was well on the G71 …


#8

Indeed, I am running the latest DisplayLink Graphics drivers - see the attached image and look at the version number. The DisplayLink Core Software is there as well.


#9

For some reason I am not able to add an image.
My Programs and Features show DisplayLink Core Software version 5.6.30904.0 installed, as well as DisplayLink Graphics version 5.6.31548.0 installed (which is the latest version). If I go to download the file you have suggested, it shows up on my computer as the same file I have already downloaded and installed.
Further, the DisplayLinkManager service is indeed running.
I don’t understand why, if I query the Device Manager, it shows the UGA-2K-A running with no problems using the older driver version and not what I have installed. Each time I have attempted the install I have uninstalled the current software first.
I alos do not understand why the diagnostic software didn’t do its job, so I have run it again, and I will email it to you sepoarately from this reply.


#10

I am receiving a message from Asus Live Update that there are new video drivers available: Nvidia Stereoscopic 3D Driver V7.17.12.6114. Should I go ahead and download and instal these? I do not want to do something that might thwart your efforts that are based upon the log files I have sent you.


#11

Hi Gary,

Thanks for your patience. Go ahead and install those updated Nvidia Stereoscopic 3D Driver drivers – the version difference won’t matter.

However, that nVidia 3D functionality is definitely high on the list of potential culpritsk. There was one other system we hit before (the HP Envy 3D laptops) which had compatibility issues (even HP’s own DisplayLink based USB graphics adapter wouldn’t work with that HP laptop). So we’ll try to untangle whether that might be it.

Thanks again,
Bernie


#12

I’ll go ahead and install the new driver. By the way, the screen I have on my ASUS is not 3D. Such a screen was an option, but I did not elect to get it. Is there a non-3D driver I can use?

Gary


#13

Hi Gary,

Yes, I bet you can jettison that unused Stereoscopic driver code. What I’d recommend first is going directly to nVidia’s page: http://www.nvidia.com/Download/index…

And choose option 2 “Automatically find drivers for my NVIDIA products.” And look for a standard driver without the Stereoscopic feature.

Now, many laptop makers limit nVidia from offering any drivers to their users (they want to steer users to get drivers only from them) So if nVidia doesn’t offer a driver from your system, that’s what’s happening and you’ll have to look to ASUS to see if they offer a non-Stereoscopic driver option.

A little bit shot-in-the-dark. Let us know if any of that pans out.

Thanks for your patience!
Bernie


#14

No change. I’m at your mercy.


#15

Hi Gary - I’m sorry, we’re stumped on this one so far.

If we’re not able to get things running, we will definitely get you a refund on both units (even though they work with the G71, and it’s well past 30 days). We don’t ever want customers stuck with product that isn’t working for them.

If you’ll give us more time, we’ll keep looking into it. But we totally understand about a refund. Just email your original Amazon order number to support@plugable.com at the point where you want to go that route, and also include a link to this support thread.

Sorry for not having any better news (yet). We’d obviously rather figure out what’s special about this setup! And we’ll keep trying at that, while we can.

Thanks for your patience!
Bernie


#16

Bernie:
I’d rather not return the devices. I’m hoping you or your engineers can resolve the apparent conflict so I can get things looking the way I want. Thanks.

Gary


#17