MSI Creator A10SE not connecting to Plugable UD-ULTC4K

My problem: Laptop does not connect to docking station. Display settings and Display Link do not recognize anything. For a moment one monitor would work. Now nothing. I do not believe it’s software or hardware because when I attach my Lenovo laptop it works fine and the dual monitors turn on immediately and everything is fully functional. All software, drivers and firmware on laptop are current and up-to-date. The laptop has both Thunderbolt and USB-C and I have tried connecting both. I am connected to the rear of the docking station but have tried the front too. Have also swapped docking station with others (my office has many) and the issue persists. I am at a loss on how to get this working.

Any tips?

MSI Creator A10SE laptop
Windows 11 Pro software.

Hello there,

Thanks for reaching out! It sounds like we’ll want to take a deeper look into this issue, and you have an internal ticket with us so we’ll assist there. Once a resolution is determined we’ll update this forum post for anyone else who may have a similar issue.


Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.