Mouse/Keyboard/Input Lag/Catch Up When Using External Monitors


#1

I’ve had the UD-3900 for several months and it has always worked great, no issues to speak of. I have an Asus Q302 notebook that I plug into the docking station so I can use an external keyboard/mouse, ethernet, bluetooth dongle, speakers, and dual external monitors without having to plug each in individually. I typically turn off the display on the notebook and use only the two external monitors.

This past weekend, the Windows 10 Anniversary update installed on my computer. The next time I plugged into the docking station, everything still worked fine (i.e., monitors, mouse, ethernet, bluetooth dongle, sound, etc.), with one small exception.

When using the external monitors, my mouse and keyboard seem to have a brief 1-2 second delay/lag followed by a “catch up” in which the mouse moves to where it should be or the keystrokes entered show up on the screen. This includes mouse clicks and click wheel movements. This happens almost every time there is an input when the mouse or keyboard haven’t been used in past 10-15 seconds, and also happens intermittently during continued use. This doesn’t totally ruin the functionality, however, the delay often makes me think that the mouse movement/keyboard input wasn’t received so I repeat it, thus after the “catch up” I have two or more of the keystrokes or mouse movements. This only happens when using external monitors. If I turn off the external monitors and use only the notebook display, while still connected to the docking station, this lag and “catch up” does not occur.

Please advise as to how best to resolve this issue. I have already updated all drivers, including the DisplayLink and the wireless mouse/keyboard.

Thank you.


#2

Hi and thanks for posting!

Thanks for the great detail you provided about the behavior, appreciate you taking the time. Based on your description, it sounds like you are experiencing behavior that DisplayLink (the maker of the chip in our dock and author of the driver) is tracking here -> http://www.displaylink.org/forum/show…

That thread is long but the takeaway is to first ensure you have the latest 8.0 M2 driver installed -> http://www.displaylink.com/downloads/… (it sounds like you already have) and if you are running your laptop with the lid closed (as you indicate you are) to temporarily open the lid to activate the internal display while at the same time using Extend mode for the additional displays (as opposed to Duplicate Mode if you are using it).

If that helps, great! If not, there is a coming update to Windows 10 from Microsoft that should help with the behavior and that is spoken to on page five of the thread -> http://www.displaylink.org/forum/show…. The specific post is here -> http://www.displaylink.org/forum/show…

Please let us know if that information helps!

Bob
Plugable Technologies
www.plugable.com/support


#3

Bob,

Thanks for the quick response. I do indeed have the latest 8.0 M2 driver installed. Opening the laptop lid and setting the projection settings to Extend mode instead of Second Screen Only seems to have solved the problem.

I’ll keep an eye out for the upcoming Windows 10 update and see if that takes care of the issue when the laptop lid is closed and I’m using Second Screen Only mode. Until then, I’ll just keep the lid open and use Extend mode.

Thanks again!


#4

Thanks for getting back with the update, and I’m glad changing the configuration helped.

Microsoft has had a pretty quick release schedule for cumulative updates for Windows 10 Anniversary -> https://support.microsoft.com/en-us/h… so hopefully it won’t be too long before the fix is pushed out.

Please let us know if you need any help in the future!

Bob


#5