Monitors stopped being detected

I’ve been using the Plugable docking station to extend my windows PC (HP Notebook 14-df0018wm) to two external monitors, using a Display Port Output (DP++).

After working fine for 5 days, the monitors are no longer being detected. Both the cable and monitors work fine.

Hello John,

Thank you for contacting Plugable support. I am sorry to hear that things are not working as expected with your UD-6950 Docking Station and I’d be happy to help investigate.

Thank you also for sharing details of your setup.

Based on your description of the behaviour, our first step is to completely reset the dock and perform a ‘clean’ manual installation of the dock’s required DisplayLink driver. I apologise if any of the steps appear in any way redundant, however the process below helps ensure that both the dock and the driver are in a good state:

  1. Please disconnect the dock from the system and please disconnect the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep everything disconnected until the last step.

  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, please just move onto the next step.

  3. Download and run the DisplayLink Installation Cleaner utility, found here --> https://s3.amazonaws.com/plugable/bin/DisplayLink/DisplayLink+Installation+Cleaner+9.1.1462.exe and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI )

  4. Once the Cleaner has been run, reboot the system (even if not prompted to).

  5. Now download and install the latest DisplayLink driver from here --> https://plugable.com/pages/displaylink

  6. Reconnect the power cable to the dock first. Once the dock is powered on (a blue light will be present on the front), reconnect it to your system. If the device is not detected, please reboot the system.

If that does not help with the behaviour, please keep the dock connected to your system (even if not working as expected), and please run the PlugDebug utility seen here: https://plugable.com/pages/plugdebug.

The tool will collect system logs into a ZIP file and save them to your Desktop.

Please send this log file to support@plugable.com and please put Ticket #344485 in the subject line so we can match things up on our end and help provide you with the next best steps. Please also let us know your Amazon order ID for this purchase.

**** Please do not share this information on the forum ****

Apologies for any inconvenience this has caused you so far and thank you for giving us a chance to help!

Kind regards,

Aga
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.