Monitors goes black and image transferred to a monitor plugged into my laptop via VGA


#1

I have two (2) new Dell 22" monitors plugged into this docking station which is connected to one of my USB 3.0 ports. I have a 3rd monitor plugged into the VGA port on my laptop.

OS Name Microsoft Windows 10 Home
Version 10.0.17134 Build 17134

Constantly the two (2) monitors plugged into the dock go black and the image is transferred to the 3rd monitor. Occasionally it is a flicker but generally it is for minutes. This happens regardless of which USB 3.0 it is plugged into. I have tried unplugging the 3rd monitor but they still go black.

I have deleted the drivers, ran the cleaner and reinstalled them without success.

Please advise


#2

Hi Paul,

Thanks for posting!

Thank you for providing those clear details about your setup, the problem, and the troubleshooting you have already done. I’d like to request some logs from your system in order to investigate further into this flickering issue.

Could you please keep the UD-6950 dock connected to your laptop (with the displays still attached), then navigate to our PlugDebug tool (https://plugable.com/support/plugdebug) and follow the instructions there?

This will create a ZIP file on your Desktop containing system logs and information. Please send this ZIP file to us directly at support@plugable.com with the subject line: “Ticket #261880

Thanks for giving us a chance to help!

Mitchell


closed #3

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.