monitor plugged into hdmi is not working


#1

HDMI output seems to not be working. I’ve switched output cables with a montior that was plugged directly into my computer and the problem is only with the monitor that is plugged into my UD-3900


#2

Hi Adam, thanks for posting! We had also received a support ticket to our direct support email address (support@plugable.com) and I just wanted to update the public facing forum post with the steps tried that had resolved the issue.

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control Panel -> Programs and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> https://s3.amazonaws.com/plugable/bin… and ensure it displays “Cleaning Complete” when done (video walk-through if you need it -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.1 M0 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation. If the device is not detected, please click the ‘Skip’ button to allow the process to complete and then reboot the system.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3

This really works. I was honestly getting worried.


#4