Monitor not displaying full width

I’m seeing black bars on the right and left sides of my monitor connected through the UD-3900.

I’m set up with a Samsung 32 inch LED monitor connected directly to my Lenovo Ideapad 330 (Windows 10), UD-3900 connected to Lenovo via Plugable supplied USB-3 cable, second monitor, a Dell D3218HN is connected to UD-3900 via HDMI.

I see the black bars on the Dell when either the HDMI or DVI cables are used. I’m running both monitors at 800x600 as I’m visually impaired and need a larger display.

When I connect the Dell directly to the Lenovo via the HDMI cable, I’m not seeing the black sidebars that are visible when running through the UD-3900.

I guess my question is how do I set the Dell display to “stretch” to use the entire width of the screen when running through the UD-3900?

Thanks for your help.

Jason

Hi Jason,

Thank you for posting! I am sorry things are not working as expected with your UD-3900 docking station and I would be happy to help.

Thank you as well for the excellent detail you provided and the troubleshooting you have already performed that is much appreciated.

The Dell D3218HN display you mention appears to have a maximum resolution of 1920x1080, which translates to a 16:9 aspect ratio. When running the display at the lower 800x600 resolution, that translates to a 4:3 aspect ratio.

Based on your description, it sounds like this difference in aspect ratio may be causing the black bars on the sides of your Dell display, similar to the effect one might see watching an older 4:3 aspect ratio TV show on a modern 16:9 aspect ratio Full HD TV.

The UD-3900 dock itself cannot control how the image is shown on a connected display, that is controlled completely by Windows and the specifications of the display itself. However, we hopefully will be able to change the behavior by making use of the Windows ‘Display Settings’ application or making changes within the display itself.

Taking a quick look at the manual for your Dell display --> https://downloads.dell.com/manuals/all-products/esuprt_display_projector/esuprt_display/dell-d3218hn-monitor_user’s-guide_en-us.pdf it mentions on page 14 that there is an ‘Aspect Ratio’ setting option available within the display’s internal on-screen menus that provides a choice between ‘Full screen’ or ‘4:3’. (I have attached screenshots from the manual below as well). If you change this option, does that help remove the black bars?

Thank you for giving us the chance to help!

Bob
Plugable Technologies

Thanks for the details.

I had previously gone down that path for the monitor setting and I just double checked and it was still set on Full Screen.

An interesting side note, my Lenovo laptop is using Intel graphics chipset and within the Intel UHD graphics control panel, I have to set Scaling to Scan Full Screen to override the primary monitor to “stretch” the display to 16:9.

Is there a way within the DisplayLink driver to force the OS/driver to full screen and “stretch” the display for monitors connected through the UD-3900? When I click on the DisplayLink icon in the Windows taskbar and choose Video Setup, it takes me to the Windows display settings pane. And there are not settings for full screen options listed for either monitor.

Thanks again for the help Bob.

Hi Jason,

Thank you for getting back to us, and I am sorry my previous suggestion did not help.

I believe I have a possible solution, however I first would like to address your most recent questions and give some background information in an effort to provide some additional context.

In earlier releases of the DisplayLink driver (prior to the release of Windows 10), the DisplayLink application icon that is located in the Windows Task Tray used to provide additional configuration options beyond what Windows ‘Screen Resolution’ or ‘Display Settings’ applications could provide, including the ability to ‘fit’ an image within a display.

That functionality was deprecated in Windows 10, so the only method to adjust DisplayLink-connected displays was from within the Windows ‘Display Settings’ application. As you have already encountered, the options within the ‘Display Settings’ application do not provide the ability to ‘stretch’ a display.

The Intel Graphics Control Panel you mention was not designed to detect or configure DisplayLink-connected displays, so it cannot be used to change the appearance of a DisplayLink-connected display.

However, Intel recently released an application known as the ‘Intel Graphics Command Center’ for the latest versions of Windows 10 (version 1709 or newer) and sixth generation or newer Intel Core platforms, and this application can recognize and configure DisplayLink-connected displays. I have written about this in detail here --> https://plugable.com/2019/03/22/new-intel-graphics-command-center/

I just did a test on my own system, and using the ‘Intel Graphics Command Center’ I was able to configure a dock-connected display to 800x600 resolution and then change the ‘Scale’ setting to ‘Stretched’. That allowed the image to fill my 16:10 aspect ratio display with a native resolution of 1920x1200 (no bars on either side).

Are you able to install the ‘Intel Graphics Command Center’ as described in my blog post, and if so are you able to configure it as I described above to see if that helps?

I have included an example screenshot from my system below for your reference, where display #1 is the dock-attached display and the display #2 is the laptop’s internal display.

Thank you,

Bob

I followed the process for installing the new Intel Command Center and it now allows me to “stretch” the second display in 800x600 mode like you noted.

Thanks so much for your help Bob, and the great customer service from Plugable.

Have a wonderful weekend.

Hi Jason,

Thank you for getting back with the update. You are of course most welcome for the assistance, and I thank you for the kind words about our service they are much appreciated.

Please let us know if you need any help in the future, and please have a good day!

Bob

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.