Monitor is not recognized by laptop


#1

Back a bit over a month ago, when DisplayLink pushed v5.3 update (or was it v5.4, don’t remember) my UD-160 stopped recognizing monitor, very similar to
http://getsatisfaction.com/plugable/t… - I run Windows 7 x64 as well.

Based on your advice, I updated drivers to v5.5 beta (5.5.27257) - this did not solve the issue though.

I’ve been traveling much since then and now I’m back home, I’m hoping to get this resolved for I could use the monitor :slight_smile:

I upgraded today to the latest DisplayLink driver v5.5.27797 - still no go.

In the Device Manager I see USB Display Adapter “working properly” with the driver version 5.5.27797.

What can I do to troubleshoot this and get the monitor attached to UD-160 recognized again by the laptop?

Thanks!


#2

Hi Serge,

Thanks for posting again. Let’s try to get this figured out!

OK - if your setup was working fine, but then was broken by the version 5.3.25973.0 update that DisplayLink pushed, then that’s our most important clue.

Background: DisplayLink pushed an update which triggered a driver signing error, apparently particular to 64-bit systems. The error would show up in device manager as a Code 52.

This driver was only pushed for a few hours - once problems were seen the update was pulled, and DisplayLink went back to the prior version. So I think the great majority of users never had time to respond to the “update available” message and get this driver. But your system did, unfortunately.

So if your setup is was working fine at some point, as a first step, I’d recommend:

* Uninstall and then reinstall the latest DisplayLink drivers. In addition to anything lingering from the prior problems, I’ve seen at least one case where a display configured under a prior version, would then not come up after an upgrade (probably because something about the way DisplayLink remembers displays in the registry, had changed between versions). A fresh install fixed it.

* At the same time, also unplug power and USB from the dock. If the dock gets in a bad hardware state, but is still getting AC power, it will stay in that bad state until power is unplugged.

Let’s just try those two simpler things to start, and if that doesn’t do it, we’ll dig deeper …

Thanks for your patience while we figure this out!


#3

Hi Bernie,

Thank you for quick reply!

I uninstalled both DisplayLink Code and Graphics, rebooted laptop, while rebooting I powered off and back on the UD-160. Once Windows booted up it discovered new USB Display Adapter and downloaded/installed drivers.

This did not help - I’d still see only one monitor in Display Resolution at that point. The version installed was 5.2.24075 and Device Manager showed USB Display Adapter “working properly”.

Then I powered off the dock, unplugged USB from laptop, uninstalled DisplayLink drivers, rebooted, installed the latest version 5.5.27797, rebooted again, while rebooting I powered on the dock and plugged USB into the laptop.

Still no luck…

Any other ideas please?

Thanks!


#4

Hi Serge,

Sorry the easy solution didn’t help here. Given the history (the bad update a few weeks ago), I’d like for us to get on the phone with you if possible to try to figure this out.

If possible, could you email phone contact information to support@plugable.com, and we’ll give you a ring.

Thank you!
Bernie


#5

I am completely lost in tring to use a new ASUS monitor with the USB 2.0 Laptop Docking Station. Help pleas WFoulk 626-538-4355


#6