Monitor connected to HDMI/Display Port 1 is flickering

I have 3 monitors connected to the docking station, and the monitor plugged into Display Port 1 or HDMI 1 is flickering.

There is no flickering when I only connect two of the monitors to the docking station, but I would like to use three monitors since the docking station should be able to support it.

I have updated the docking station driver and verified that my Dell Latitude 5530’s software is up to date, but nothing seems to resolve the flickering issue.

Hi @jsmith29118,

Thanks for posting!

Sorry to hear about the flickering behavior. When you mention that there is no flickering when you connect only two monitors to the dock, does that mean if you connect two monitors to say the “HDMI 1” port and the “HDMI 2” port, the flickering ceases on the HDMI 1 port?

Next, if you swap two monitors between the HDMI 1 and HDMI 2 or 3 port, does the flickering follow whatever monitor is connected to the Display 1 video group?

Thanks for giving us a chance to help!


That is correct, there is no flickering when I only connect two of the monitors to the docking station, but I would like to use three monitors since the docking station should be able to support it.

No, the flickering is always coming from Display video group 1 when I have 3 monitors connected to the docking station.


Thanks for the additional information.

That’s a bit strange to hear how the flickering is actually correlated to the number of displays connected, not just the physical video port on the dock itself. We’ll definitely want to look into this further.

At this point, I’d like to request some log files from your system to take a closer look. Could you please keep all three displays connected to the dock, then navigate to our PlugDebug tool and follow the instructions there?

This will create a ZIP file on your Desktop containing system logs and information. Please send that to us at, and you can include “Ticket #420744” in the subject line to help match that case up to this post.

Thanks for your patience!


Just sent the email.


Thanks for doing that! I just checked and I’m not seeing a support ticket that has came in that has the subject line “Ticket #420744”.

It’s possible it may not have went through, possibly due to attaching the ZIP file containing system logs. Can you try sending that email again, this time uploading the log files to a cloud storage service such as Google Drive or Dropbox, then share the link? Note, please make sure that the file is accessible to anyone with the link.

Thank you and sorry about the obstacles here!


Hi Joshua,

Thank you for having the logs sent to us! I would be happy to provide support going forward.

For my reference, does the same problem occur if the dock is connected to a different USB port on your laptop, or to a different laptop (if available)?

Additionally, does the behavior change if you disconnect all USB devices from the dock/laptop (for testing purposes)?

Looking further into the log contents, I noticed that the current system BIOS is a bit outdated according to Dell for this laptop. The recent updates do have quite a few relevant fixes, so I would recommend updating to the latest BIOS version provided to see if that helps. To do this, please follow these steps:

  1. Save and close all open applications. Disconnect the dock from the computer, then ensure the computer is connected to power
  2. Download and execute the following BIOS update provided by your computer manufacturer:
  3. Follow along any listed steps, then your computer should reboot and the BIOS update should start
  4. Upon completion, log back into Windows, then reconnect the dock to your computer

Please let me know if that helps at all.

Thanks for your patience while we work to help!

Plugable Technologies

So, the problem still occurs when I plug the USB C cable into the secondary USB C port. I have another docking station that is the same model and the problem occurs on that one as well. However, I do not have a spare laptop that is the same model to test if the problem occurs with the same docking station but just a different laptop.

No, I have already tried the recommendation from my research to disconnect all connected USB devices to no avail.

I updated my computer’s BIOS to the most recent version and the issue still persists.

Hi Joshua,

Thank you for letting me know!

Moving forward, could you kindly send an email to with the subject line of “Ticket 420744” so that we can prioritize that case and match it to this inquiry? I ask because we would like to keep your user information private going forward.

If you could provide your Amazon Order ID (or other proof of purchase) associated with your Plugable device, I would be happy to check on your warranty status as well.

Thank you for giving us the chance to help!

Plugable Technologies

RW Note: Set to solved, responded directly.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.