Microscope function lost

Hi Guys,
Like to find fixes myself as I always learn something new, but been beating myself up for a day trying to solve this loss of functionality. Worked fine until 1803 update. Have tried everything discussed prior in this forum but no joy. Camera function works fine but now need microscope again for my biz. Software reinstall many times, dev. mgr. checked, camera privacy set ok. Reboot, reboot, reboot. HP laptop, win 10, good resources.

Viewer displays device selections for both camera and microscope but LEDs do not activate for microscope, mottled grey image area is displayed (no actual image) and resolution dropdown choices are blank. Gray images only are captured from any selection choice.

Any insight would be greatly appreciated as this product fit the bill perfectly when it worked. best


Thanks for reaching out to us! Sorry for any trouble you’ve had with the microscope, and I’d be glad to help. With respect, our support services are limited on the weekend.

To be clear, the microscope image works, but the led lights do not? I just want to be sure that I understand the situation. It seems you’ve run through quite a bit of troubleshooting. May I ask, are you able to try the microscope on another computer to see if you get the same result? That would be helpful, but, I understand if this isn’t possible.

I see you’ve also sent in a direct email request. Let’s continue to chat through the direct email to make sure we get you the best personal support.

Thank you,

Plugable Support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.