Microphone output not detected by Online Rosetta Stone


#1

Hi,

I am using the DC-125 multifuction devices with Microsoft Multipoint 2011. It is running on a Dell R210 Server with an ATI Firepro 2270 graphics card. I am plugging in headsets with 3.5" headphone with seperate microphone as the device requires. The workstation is detecting the microphone and getting signals from the microphone.

I am trying to use the online subscription version of Rosetta Stone for a non-profit school. The Rosetta website utilizes flash to access headphones and microphone.

I have been unable to get Rosetta to use the microphone. It does not hear it at all. I have changed the flash settings such that the website is allowed to use all resources and have even noted that in the flash settings dialogue, the meter shows the microphone working as it is showing feedback.

Going in to the “Preferences” of the website to configure the microphone, it shows me a list of microphones to chose which, I am assuming is all the multifunction devices plugged in to the hub. The microphones are all numbered like numbers 80 or 148 or whatever. No matter which one I chose, none of them are detected as having any sound. (I have no idea which microphone to chose) I then will go back to the recording device preferences to check for feedback from the microphone which it still has.

I am at a loss. If one calls Rosetta for support, they have no clue about multipoint server. If you utter the words terminal server, they quickly and loudly say, “we will not support terminal servers.” Unless I am totally wrong, I am pointing to the way they interface with flash and are not properly getting a signal from it. From my limited posting, am I wrong?

Things I have done:
Tried different multifunction devices
Tried different headsets
Changed the power settings so that USB never sleeps
Reinstalled Displaylink
Changed USB IRQ ports (After updating server bios)
Purchased new USB Hubs

Thank you for any help you can provide.


#2

Oh, by the way, this setup has worked extremely well for one full school year to which we are now 2 months in to the second school year. I am using 12 workstations set up with the DC-125. We have been overjoyed by the limited amount of maintenance, much less power requirements than running 12 full standalone computers, and the list goes on and on.

In my opinion, VDI this is the future.


#3

Hi Mike - Thanks for posting! It’s wonderful to hear of the (overall) success at the school over the past year. Not enough people realize how amazingly easy and useful this kind of setup can be. The low maintenance and much lower power consumption are huge advantages.

That said, Microsoft’s Windows Multipoint Server 2011 is having to do some tricks to treat many USB devices on the system - like sound - as being “owned” by individual terminals.

My guess is that Adobe Flash (or whatever Rosetta is using) is using lower-level APIs to query the set of audio devices available to them – and thus finding all the audio devices for every terminal. Whereas, if it used the normal Windows sound APIs, it would get the right thing – only the audio devices attached to the terminal.

First a quick question: does the microphone attached to the terminal work with other applications (not through Flash)?

Thanks for letting us know - we’ll then see if we can find a settings change (perhaps in Flash itself) to find our way past this.

Thanks again!
Bernie


#4

Thank you Bernie for the quick reply! I don’t know if you remember it but It was because of you that we got this setup running because of figuring out about the Matrox G200 card and then putting in the ATI Firepro 2270.

I definitely understand what you said. To answer your question, I have used sound recorder and it worked but have not tried it in any other application.

What’s interesting about flash is that in the settings, it gets feedback from the microphone. It doesn’t say which one except for “remote audio.”

I am going to throw you an exeption here that is driving me CRAZY. It did work one time on one terminal. I have not been able to reproduce that. Nor did other terminals work when that happened.

I apologize for my frustration.


#5

Hi Mike - Ah great! It sounds like the audio device on the terminal is working, but the issue is getting Flash to use the right one (because WMS will only let the one actually attached to that terminal work).

I think since Flash is bypassing the top-level Windows sound APIs and listing every microphone on every terminal, probably the “right one” is there hidden in the list - so that might explain the one time it worked. It’s still not good behavior, though.

I’m suspecting a general Flash / WMS 2011 problem here - if so, we’ll try to see if we can get Microsoft and/or Adobe in the loop to confirm and try to look for workarounds.

Just for background (none of these provided a solution though), here’s some background:

Adobe’s main page on sound configuration:
http://www.macromedia.com/support/doc…

Rosetta Stone’s on microphone setup:
https://resources.rosettastone.com/as…

Microsoft’s details on WMS 2011 and USB devices:
http://technet.microsoft.com/en-us/li…

So the one thing I can think of is trying a different version of Adobe Flash that might have better behavior. Can you say what version of Rosetta Stone you have? From that, we’ll be able to look at what level of Flash it requires, and know whether there’s any older or different versions we can try …

Thanks!
Bernie


#6

Thanks again Bernie.

I understand the path you are going down but it isn’t necesarily the issue. Flash Player detects “remote audio” and shows active feedback from the microphone. You can see this in the flash settings|microphone settings. Also, if I change the “record volume” the gain definitely changes.

So, that being said, I hit “close” on the settings window, go back to Rosetta online and it hears nothing.

As I type this I had an epiphany, I think. Why would flash player only show me one device being “remote audio” yet Rosetta Online shows me all the usb physical devices with no “remote audio?”

It HAS to be in the programming of Rosetta and the way they use flash resources. I think you might have hit the nail on the head in your first post.

BTW, I am using Flash latest version 11,4,402,265. I updated from the version before this just for this issue.

I wish I knew about flash code and its api’s. In order to fully troubleshoot this, I need Rosetta programmers, right?

Michael


#7

Hi Mike,

Great background. Yes, there seems to be a disconnect in how Rosetta uses Flash – which means Rosetta is in the best position to solve the issue. Perhaps with this extra background, you could take a second run at getting their thoughts and suggestions?

Let us know if we can help in any way - we’ll do everything we can.

Thanks!
Bernie


#8

I went to the trouble of writing my own Flash app and have no trouble detecting and using microphone input on the Microsoft Multipoint environment.

In Rosetta Stone Online, they enumerate the detected devices to the exact USB device aka 86 - USB Device, 94 - USB Device, etc., I know of no way to find out which device is numbered what. Do you?

If I go into the flash settings, it shows “remote audio” and is working with input from the microphone just fine.

In Summary, Rosetta Stone Online wrote their own flash api that wrongly enumerates the microphone devices. The problem is that there is no way to get through tech support to a person in Rosetta Stone that actually wants to address and fix this problem.

I am writing this here so that Google will cache it. If anyone else has issues and spends hours and hours trying to fix this, they will see Rosetta Stone Online will not support Microsoft Multipoint Server. If one wants to use Rosetta in any way, they force a standalone system.


#9

Hi Michael,

Thanks so much for doing that Flash test to confirm things, and documenting the situation with your reply. That’s super-helpful to others who come along and hit the same thing, frustrating as it is.

Thank you!
Bernie


#10

Your thread was very helpful for me to resolve this problem. I am only a single user, but I had problems getting the microphone to work on the website. Based on what I read here, I knew it was a Flash conflict, but still couldn’t fix it on my own. I was able to relay that information to the support rep at RS. He had me update my Flash to 11. I also changed my browser Flash setting. One of the two things fixed it and it works perfectly now. Thanks for posting!


#11

please help me!it’s problem with microphone" !](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1303473/Untitled_inline.jpg?1446479570)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1303473/Untitled.jpg?1446479570)


#12