mdp-hdmi adapter 4k@60Hz TV with MacbookPro issue


#1

I am trying to use the mdp-hdmi adapter Rev B on my new TV (Sony x800D) along with
AmazonBasics High-Speed HDMI Cable
on my Late 2013 15 inch Macbook Pro and It wouldn’t work at 3840x2160 @60Hz, it could only do 30Hz in macOS Sierra.

Thing is I have an older Samsung 4k monitor that I usually connect my mac to using thunderbolt to DP and I can get fine 4k@60hz.

Any idea why I can’t get it to do 4k@60 on my mac?

PS:
I also performed a test using the same TV, same HDMI cable to another PC running a gtx 1070 and managed to get 4k@60fps no problem so the HDMI cable should not be a problem.


#2

It’s not clear whether or not you tested the mdp-hdmi adapter on the other PC. That would tell us if the adapter works.

You could try Windows or Linux using Boot Camp on the MacBook Pro to be sure that there’s not a problem with the mini DisplayPort.

If the adapter works, and the mini DisplayPort works, then there’s a problem with the Mac OS graphics driver. There’s a patch that might work (I haven’t tried it) at
https://github.com/Floris497/mac-pixe…


#3

Ok so I performed 2 tests.

I used the adapter with my PC (using a GPU with an mDP) and I managed to get it to work with 4k@60Hz.

I also ran a test on the macbook using window 10 bootcamp and it does not seem to want to do 4k@60hz so it seems like the macbook pro late 2013 can do 4k@60hz on mDp to DP on monitors but not mDP to HDMI 2.0 too bad…


#4

It could be that the Windows graphics driver has the same incorrect limitation as the Mac graphics driver or maybe the port just doesn’t support 4K at 60 Hz. The patch I linked was originally for removing a 165 MHz pixel clock limit for HDMI to allow resolutions higher than 2K at 60 Hz. 4K at 30 Hz requires 262 MHz. 4K at 60 Hz requires 533 MHz which may be beyond the capabilities of the port. Maybe the patch can fix this case, or maybe a different patch could be made…

The 15 inch MacBook Pro Late 2013 has Thunderbolt 2 ports which are supposed to support DisplayPort 1.2. The Apple document at https://support.apple.com/en-us/HT206587 says that the MacBook Pro (Retina, 15-inch, Late 2013) is supposed to be able to do 4K at 60 Hz using MST. Are the DP monitors you’ve tried set to MST?

I guess the mdp-hdmi adapter requires SST?

I would like to know why a port that can do 60 Hz via MST can’t do the same using SST? Also, how difficult would it be to make an HDM 2.0 adapter that can take as input a DisplayPort MST signal?


#5

Thanks for the info.

So the monitor I am using with my mac that 4k@60Hz works fine is the Samsung U28D590D using thunderbolt to Display Port. That one supports max 4k@30Hz over HDMI to HDMI. Reading the specs I believe that samsung monitor supports SST, I’ve never set it manually to MST not I can find a reference to MST settings.

I’ll try out the patch you linked and see what happens.


#6

Found this link which says the U28D590D is SST:
https://twitter.com/Thracks/status/45…
I can’t find better evidence than that. I also found this next link which emphasizes the single screen (not using MST) feature:
http://www.tftcentral.co.uk/reviews/s…

If the U28D590D works with your MacBook Pro (Retina, 15-inch, Late 2013) at 4K @ 60 Hz, then it means that that MacBook Pro supports SST 4K @ 60 Hz and Apple’s HT206587 document is wrong.

It also means that that MacBook Pro should be able to give the mdp-hdmi adapter a SST 4K @ 60 Hz signal. Maybe Apple’s driver is getting some information from the adapter or the 4K HDMI display that makes it choose to only allow 30 Hz. The patch should eliminate that incorrect logic.

There may be other issues affecting this though (not likely) such as color space and pixel depth/format (RGB, YCbCr 4:4:4/4:2:2/4:2:0, 8/10/12 bits per component). In that case, you’ll want to check the EDID which can be overridden in Mac OS X. In Mac OS X, the screen should be set to display millions of colors (I think this means RGB 8 bits per pixel but I’m not sure it couldn’t also mean one of the YCbCr formats). Don’t try billions of colors (10 or 12 bits per component - not sure which) until you know millions works. Actually, RGB and YCbCr 4:4:4 probably don’t work at more than 8 bits per component for 4K @ 60 Hz. Apple should add a setting for switching between RGB and YCbCr in the system preferences UI. Otherwise you have to override the information from the EDID if you want to change the colorspace.

To answer my question of why a port that can do 60 Hz via MST can’t do the same using SST, some people suggested that a graphics chip might be able to generate 2 streams of 262 MHz but not one stream of 533 MHz of graphics data depending on the graphics core clock which could be limited on laptops to save power. The DisplayPort chip will happily transmit the 2 streams of MST having similar bandwidth to one stream of SST.

As for how difficult would it be to make an HDM 2.0 adapter that can take as input two streams of DisplayPort MST signal, I guess that depends on what kind of synchronization there is between the two streams. If they are in sync, then an adapter would need to only capture a line or two of data at a time. If they are not in sync, then an adapter would need to capture an entire screen’s worth of data.


#7

Hi Nik, thanks for posting! We have recently discovered these issues with our adapters when running on Mac OS X/macOS where they are unable to display 4K resolutions at 60Hz, as we do not have the older MacBook Pros and Mac Pros in our labs to test.

Seeing as you have BootCamp access, we can certainly provide steps to preform a firmware update within Windows and then test within macOS to see if the firmware helps in achieving a 4K@60Hz resolution.

A workaround that has worked for some customers is to use a 3rd party application called SwitchResX (http://www.madrau.com/) in order to “unlock” that resolution or set a custom resolution, but we have had a mixed bag of results with this application too.

Unfortunately, other than applying a firmware update or test using SwitchResX, there is not much else we can suggest to try on the Mac side of things.

Please let us know if you’d like to try a firmware update or let us know the results with SwitchResX and we will go from there.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#8

Apple’s drivers should create resolutions depending on the reported (or assumed) capabilities of the display, the DisplayPort adapter, and the graphics hardware. SwitchResX is used to create custom resolutions that the drivers do not automatically create.

Custom resolutions created in SwitchResX are validated by the graphics drivers which may choose to disable any created custom resolutions based on the reported (or assumed) capabilities of the display, the DisplayPort adapter, and the graphics hardware.

If the graphics drivers are incorrectly disabling resolutions that have pixel clocks greater than some fixed value for the port that you want to use, then a patch for the Apple drivers may be required. So you made need both SwitchResX and the patch.

However, if the drivers disable a resolution because of something reported by the firmware of the mdp-hdmi adapter, then a firmware change could fix it without the need for a patch.

SwitchResX can save the EDID for a display. Use the “Export EDID” button. This will contain information about the capabilities of the display.

For each display, SwitchResX shows in the Display Information tab the allowed frequency ranges of the graphics hardware (maybe even DisplayPort adapter - I’m not sure). The max pixel clock frequency should be greater than 533 MHz to allow 4K @ 60Hz. If not, then a patch may be required.

To get the capabilities of the DisplayPort and DisplayPort adapter, then Linux (such as Ubuntu) can be used to dump the DPCD information (this is like EDID for the display but is for the DisplayPort/DisplayPort adapter). If a firmware update fixes your problem, then it would be interesting to know if there are changes in the DPCD that are the cause of the fix. Maybe all the adapter has to do is not report itself as HDMI (if it’s even doing that now?) because it’s an active DisplayPort adapter and there’s no reason for the OS to know what’s on the other end of the adapter (except for the EDID information which describes the resolution of the display, which you can override).


#9

Hi David, Thank you for your comment. Unfortunately, I returned the product 2 days ago as per the instructions of one of the Customer Service Representatives.

I did indeed try out SwitchResX and even the driver patch that @joevt proposed with no luck unfortunately.

I’m open on trying the firmware update but unfortunately I don’t have the product any more.


#10

Here’s a YouTube video that shows you which USB-C to HDMI Adapter works with the new Macbook Pro and how to change the settings in the native system preferences.

https://www.youtube.com/watch?v=o46OM…


#11

Hi David, I would love to help you test with this configuration. I have a MacBook Pro late 2013 with NVIDIA GeForce GT 750M 2048 MB. I can do a firmware re-write of the Plugable mdp-hdmi-adapter. I believe if we can achieve MST emulation for SST HDMI 4K displays then this would open up a significant market for 4K display usage on older Mac hardware.

You can reach me at:
aaron@steampunk.digital


#12