MBP - Only 1 of 2 monitors work, even after updated drivers

I have an M1 MacBook Pro running latest MacOS. Display #2 (the DisplayLink-connected display) will not come up. I deleted DisplayLink Manager and installed the updated version. It worked. Then I restarted, and I cannot get it to work again. The HDMI display comes up every time without any problem. Anyone have any thoughts on how to get the DisplayLink display to work?


As a followup to the above, it seems that connecting my MBP to the docking station interferes with programs launching, like basic apps like System Settings, Finder, etc. As soon as I unplug the dock, the apps launch. This seems more puzzling, as this system seemed to work fine before I moved all of the hardware to another room.


Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

Quite odd indeed that this only began after moving the hardware around and that when the dock is attached the system isn’t running programs correctly or outputting to the additional display.

A few super basic double checks:

  1. Are you still using the USB-C to USB-C cable the dock shipped with (black, 1M)? I have seen if the C cable is switched to a different one where it may not support the dock properly and cause some unexpected behaviors.

  2. Do you recall what version of the DisplayLink Manager app was installed during the uninstall/reinstall process? (1.8.0 should be the most recent)

  3. Are other dock functions still working that you can tell? (USB ports, audio, Ethernet, charging?)

What I can suggest proactively, let’s try resetting the dock and Mac to see if something is just stuck in a bad state:

  1. Unplug the dock from the Mac and unplug power from the dock. Please leave the dock disconnected until the final step.

  2. Fully shutdown the Mac. (On your Mac, click the “Apple” menu and select “Shut Down”)

  3. After the Mac has shutdown, wait for 60-90 seconds, then turn the Mac back on. (This is to ensure the system is fully off and that the USB-C/Thunderbolt controller fully resets.)

  4. After logging back in, wait about 30-60 seconds, then plug power into the dock first and plug the dock into the Mac next (using the provided USB-C cable the dock shipped with) and see if the behavior has improved.

If things still aren’t working as expected we should probably take a closer look to see what could be happening. We have a troubleshooting tool that helps us find out what is going on in situations like this. If able, please plug the dock with your accessories attached to it into your computer, then go to this page and follow the instructions there:


I can then look to see if anything looks out of place and hopefully offer some suggestions. When emailing us the diagnostics results please mention ticket 395643 in the subject line, please don’t post the diagnostics here!

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies

Hi Joshua -

Thanks for your response. In answer to the double checks: 1. yes, I’m using the USB-C cable that came with the station; 2. I want to say the prior DL version was either 1.3 or 1.4 (I now have 1.8 installed); and 3. yes and no: charging seems to work, but only 1 of 2 USB drives connected is recognized (I don’t use the audio or ethernet ports yet).

I tried the dock reset that you provided and so far it seems a partial success. System Settings came right up when I opened it up. So did the Finder. I’ll continue to monitor whether those work properly. However, the 2nd monitor still does not come up. The HDMI-connected one seems to work just fine; the DL-linked one, not so much.

I did the debug at the time I posted this, so I’ll submit to you all and see if you can diagnose whatever it is that needs to be fixed.


Joshua -

I spoke too soon. When I went to write an e-mail and submit my debug log, I couldn’t attach the log because the dialog box wouldn’t appear and Firefox got the spinning beachball. As soon as I unplugged the dock, it came up immediately.

The log has been submitted. Thanks.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.