macOS Ventura upgrade caused dual ext monitors to stop working until reducing refresh rate

I use the TBT3-UDZ with my MacBook Pro 16" 2019 x86. I have two external monitors; an LG 4K and an ASUS 1440p. They’re connected to the HDMI ports on the dock. Both monitors worked fine at 60Hz refresh rate with previous versions of macOS.

Immediately upon upgrading to macOS Ventura 13.x I could only get one monitor at a time to work until I reduced the 4K monitor’s refresh rate from 60Hz to 30Hz. I’ve tried a lot of other things, e.g. rebooting, disconnecting & re-connecting devices in different orders, etc. I haven’t found another workaround.

It seems like a bandwidth limitation – is it connecting to the dock as USB-C instead of Thunderbolt? I don’t know how to tell.

I would appreciate any troubleshooting suggestions or resources.

Hello Jeff,

Thank you for contacting Plugable support! Sorry to hear about this issue. I’d be more than happy to assist you.

We have a troubleshooting tool that helps us find out what is going on in situations like this. If able, please plug the dock with your monitors attached to it into your computer, then go to this page and follow the instructions there:

When sending us the diagnostics results please don’t post them here, rather email them as an attachment to support@plugable.comand mention ticket #394113 in the subject line.

I can then look for any obvious causes from a software perspective and check the current bandwidth, etc.

Please don’t hesitate to let us know of other questions.

Thanks again for contacting Plugable support and best wishes!

Joshua Henry
Senior Engineer | Product Owner
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.