Macbook Pro M1. Only 4K or 1080P resolutions are available for 27" Monitor. 2560 x 1440 is ONLY in Low Resolution

I just bought Plugable UD-6950 dock station to connect 2 monitors to MacBook Pro M1. After connecting 2 monitors on 27” monitor I have a choice only between 3840x2160 or 1920x1080, resolution 2560x1440 is only in Low resolution. Second 24” monitor has 1920x1080 as it should. I am not sure why I can’t choose the resolution that I always worked on my previous MacBook Pro 2015. Drivers were installed as per instruction, computer Macbook Pro M1 MacOS 12.01.
What should I do if for work I need to connect two 27” monitors with 2560x1440 at 60Hz?

Also I tried to connect 27” monitor via USB-C and all high resolutions were available

Hello,

Thank you for contacting Plugable! I’m sorry for the trouble with your UD-6950 on your MacBook Pro 2020 M1, and would be happy to share some information with you on this.

Unfortunately this is a known issue with DisplayLink on the M1 macs at this time. I am unable to provide any sort of time frame for a fix for this either.

This user on the DisplayLink forums was able to find a work around that they have had good success with (we can not verify or support this at this time however), you can find that here → https://www.displaylink.org/forum/showthread.php?t=67982

I apologize that I do not have a better solution for you. Please let us know if we can be of any further assistance.

Sean
Plugable Technologies