Macbook Pro 2017 Display issue


#1

I have a UD-CAM which I intend to use in output video to my Dell P2314HT monitor using HDMI. I connected the monitor to the dock using a HDMI to DVI cable, as the monitor doesn’t have a HDMI port. But there is no video signal being sent according to the monitor status. The USB ports and the charging through the dock work fine. What options do I have?


#2

Hi TJ,

Thanks for posting!

We see that you’ve reached out to us directly at support@plugable.com, but I will go ahead and walk through our initial troubleshooting steps here as well to keep this topic updated.

We always want to make sure that the original USB-C cable that came with the UD-CAM is being used because not all USB-C cables are created equally and there can be issues with the various functionalities of our USB-C docks if an unsupported third-party USB-C cable is used.

Next, we’ll want to perform a power-cycle of the UD-CAM. To do this, please perform the following steps:

  1. Disconnect docking station from host machine and power adapter

  2. Leave unplugged for 1 minute for power to dissipate

  3. Connect docking station initially into power only and confirm blue indicator light is on

  4. Connect docking station to host machine using USB-C cable and test for functionality

  5. If the above steps do not change the behavior, rebooting the host system may restore functionality

If this is of no help, could you please follow up with your Amazon Order ID number over email (not here)?

Thank you!

Mitchell


closed #3

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.