MacBook Air M2 - DisplayLink & Parallels Incompatability

I have a MacBook Air with a M2 chip

  • Recently installed Parallels and created a Windows virtual machine

  • VM works fine but when I shut it down I cannot restart it and get INACCESSIBLE BOOT DEVICE

  • I need to create a new virtual machine image which works fine until I shut down virtual machine and restart it again.

  • After spending a month working with Parallels Support they determined that DisplayLink video driver is incompatible with Parallels and said to reach out to DisplayLink/Plugable

Anyone else with this issue? Any workaround?

Hi Edward,

Thanks for reaching out to Plugable support!

I have responded to your support ticket in more detail and will update this post later.

Richard A
Plugable Technologies

I tried the steps in the link that was sent to me and I am still having the issue. I had virtual machine running and shut it down, tried the steps in the link you sent, tried restarting the virtual machine and once again had INACCESSIBLE BOOT device.

Per Parallels Support “Unfortunately, Parallels Desktop does not support the DisplayLink drivers at the present time.” Please try the steps below. These steps should make the virtual machine run using your actual macOS graphics driver, preventing the issue from reproducing (for a permanent fix the issue should be addressed to the device’s vendor or Displaylink driver developers).

  1. Disconnect the DisplayLink hub from the Mac.
    • Ensure that the hub is physically disconnected from your Mac.
  2. Shut down the virtual machine.
    • Close or shut down the Windows Virtual Machine that is running on your Mac.
  3. Restart your Mac.
    • Completely restart your Mac computer.
  4. Connect at least one of the external displays directly to the Mac or have the lid open when the virtual machine starts.
    • Connect one of your external displays directly to your Mac, either via the appropriate cable or by ensuring that the lid of your Mac is open if you are using the built-in display.
  5. Run the virtual machine on the Mac’s main display.
    • Start the Windows Virtual Machine, making sure it runs on your Mac’s main display.
  6. Connect the DisplayLink hub and other monitors.
    • Once the virtual machine is running, and you have successfully logged in, you can connect the DisplayLink hub to your Mac and then proceed to connect your other monitors to the hub.

Following their steps and the steps in the link you sent have not solved this issue. I am hoping you can come up with a solution to resolve this.

Hi Edward,

Thanks for the update.

Before we go too much further into this, it would be very helpful to know what model of our product you are trying to use. You should be able to locate this information on a sticker from the bottom of the device.

Thanks again for working with us and giving us a chance to help.

Richard A
Plugable Technologies

I have the UD-ULTC4K. Plugalble USB-C Triple 4K Display Docking Station.

Hi Edward,

Thanks for the update.

I did want to clarify if you have installed and completely set up the display link manager on this Mac. If so, it would be helpful if you could click the display link manager icon from the top menu bar and send us a screenshot of that window.

Hopefully this will tell us if we are missing anything with the initial setup or not.

Richard A
Plugable Technologies

Attached is the requested screenshot

Hi Edward,

Thanks for the update and your patience while we try to help out with this issue.

I did consult some of the other team to see if we could figure out what could be going on here and it looks like we found a bit of information that we hope might help with this issue. I did want to share this KB article that we found to set the expectation that Parallel does not support DisplayLink products. While it was last updated in 2020, given your most recent exchange with Parallels support, this may not have changed. However we’ll do our best to investigate further.

One thing that we would like to ask you to try for the next time you are done using this setup is to first disconnect the docking station from the computer and then quit out of the DisplayLink Manager application by clicking into the app on the top menu bar and clicking the “Quit” button. The previous instructions from Parallels did not include this step, so hopefully this will help us determine if the DisplayLink Manager app is the cause of the issue or not.

Additionally, it would be very helpful if you could upgrade to the latest version (1.9.0) of the DisplayLink Manager App to see if this makes a difference with Parallels, which can be found on the DisplayLink drivers website:

You may want to refer to the following knowledgebase article for installation steps (however use the download link above for step 1):

Please let us know if you have any questions about this and thank you for giving us a chance to help.

Richard A
Plugable Technologies

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.